5

I am working in QGIS 2.18. When I open and then save a .tab file as .shp file I get different symbols in the letters of the attribute table. I don't know what coding option I should use in order to see the original letters (Spanish alphabet symbols: ñ, accents, etc...).

enter image description here

By default the "save vector layer as..." dialog window chooses UTF-8.

enter image description here

I already tried some other options but I get unreadable text, so I rather ask before I do something that hurts the file.

In fact, when I open the .tab file in MapInfo I can see it correctly. Is it something related to the system settings of the program (QGIS/MapInfo)?

7

You can use ISO 8859-1 encoding to read Spanish text correctly (along with various other countries).

  • I did as you suggest it but I get question marks "?" now instead of question marks over a black diamond. – Pescariz Nov 29 '16 at 11:45
  • @Pescariz - I cannot replicate your issue. I have a .tab file containing similar text with accents etc and I used the ISO 8859-1 encoding when using the Save As... option. Output shapefile produces the correct result. Could you upload your .tab files to a public server so that others could test it? – Joseph Nov 29 '16 at 11:53
  • 1
    It must have been because I had the file opened in MapInfo while working in QGIS. Closed both programs, started QGIS, and did all the procedure again and now it works perfect. Thanks a lot. – Pescariz Nov 29 '16 at 12:14
  • @Pescariz - That makes sense, glad you got it working ;) – Joseph Nov 29 '16 at 12:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.