I am working with this natural earth shapefile. The dateline disappears after using the mentioned clip to hemisphere plugin. Densifying the geometry does not help.

Weird to me seems that clipping to a hemisphere centered at lat -76,98267 / lon -163,36119 works just fine (dateline present after clip) while after clipping to a center at lat 26,50588 / lon -171,82873 the dateline dissaperes although it should be visible.

Solved as noticed in the comments by @Jake a bug in the clip to hemisphere plugin is the problem. I quickfixed it and its all good now.

closed as off-topic by PolyGeo Dec 2 '16 at 12:53

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This problem cannot or can no longer be reproduced. Changes to the system or to the asker's circumstances may have rendered the question obsolete, or the question does not include a procedure to enable potential answerers to reproduce the same symptoms. Such questions are off-topic as they are unlikely to help future readers, but editing them to include more details can lead to re-opening." – PolyGeo
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Have you tried the Vector > Data Management > Define Current Projection tool? There is also a "Reproject Layer" tool in the Processing toolbox. – GIS_Canuck Nov 29 '16 at 16:49
  • Possibly try densifying the geometries. – mkennedy Nov 30 '16 at 0:30
  • If the reported failed values are in radians, they're either approximately 30, -13.5 or the reverse (not sure which is latitude). It's probably lat=-13.5 lon=30, which is very, very close to the "horizon"/hemisphere edge. (This assumes center is -77, -163). – mkennedy Nov 30 '16 at 3:39
  • @AndreJ: Using decimal points instead of commas fixed the problem when I tried to reproduce the error. Note that removing the features from the rear of the view is what the ClipToHemisphere-Plugin does (which simooooon used in step 1). – Jake Dec 1 '16 at 11:57
  • 2
    This is a bug in the Clip to Hemisphere plugin (I've opened a ticket). As a quick fix, you can change the 180 in github.com/jdugge/ClipToHemisphere/blob/master/… to 180.1 in your local copy of the plugin (in .qgis2\python\plugins\ClipToHemisphere in your home directory), then restart QGIS. I'll fix the error and upload a new version of the plugin on the weekend. – Jake Dec 1 '16 at 16:45