5

I m using QGIS 2.18

I export data from SQL Developer to a csv file with ";" as separator and with UTF-8 encoding.

Then, I have imported the csv with UTF-8 encoding. Accents were imported right. enter image description here

But after processing a join by attributes between CSV and a Shapefile with .cpg "UTF-8" the accents disappear:

enter image description here

What's the matter? Is it from ogr2ogr sub "processing" that does not support the accents?

  • Please specify exactly which tool was used for the join by attribute operation. – underdark Nov 30 '16 at 15:13
  • EDIT : In Modeler, i use field calculator to convert the floats number into integer in the csv table then i can join on this new field the Shapefile where the numbers to join are integers. I see the problem appears at the Field calculator step. I just tested with a join with no match (because of float numbers) and the accents are ok – jlSta Nov 30 '16 at 16:24
  • Thanks to @rjhale This is a bug There is a workaround but how could i implement it in models? – jlSta Dec 8 '16 at 17:07
2

Works for me. Checked in 2.18.3

Change the Processing encoding in Advanced Settings 'System' to 'UTF-8' or any other encoding

Processing Encoding

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.