I have an ArcMap MXD file with multiple layers containing points associated with an URL that can be visited using the hyperlink tool. Some layers contain many points, other contains few.

My problem is that when I select the hyperlink tool blue dots are displayed for all points, even from layers that are not visible (i.e. unchecked in the ToC). This makes it near impossible to click points in one of the layers containing few points, since the screen gets completely cluttered with points from the denser layers. The screenshot below illustrate the problem - only two of the blue dots are from points in the visible layer that I would actually like to click. Good luck finding them.

Screenshot of map.

Is there any way to make ArcMap only display blue dots for the visible layers? Limiting it to a selected layer would also be an acceptable solution.

  • You could disable hyperlinks on the non visible layers or use the identify tool and launch the hyperlink from there. Commented Nov 30, 2016 at 16:05
  • @ChrisR Disabeling all the hyperlinks would be quite a manouver since it would require something along the lines of 5 clicks per layer... But using the identify tool instead is a great idea - thank you!
    – Anders
    Commented Nov 30, 2016 at 16:36
  • 1
    ...but the identify tool opens my links in IE. Argh.
    – Anders
    Commented Dec 1, 2016 at 12:13

1 Answer 1


Are you using group layers? I was struggling myself but found that when the top group layer is unchecked but the sublayer is still checked, the hyperlink tool draws the sublayer in blue. Unchecking the sublayer removes the layer in the display.

You could also try to uncheck the highlight color for hyperlinks in the Customize->ArcMap otions->General tab. This removes the highlight color completely, so you can't see which layers are hyperlinked, but that may be to prefer if you know that already.

  • Both solution works like a charm! The checkbox thing sounds a bit like a bug to me. Thanks!
    – Anders
    Commented Dec 14, 2016 at 8:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.