4

I upgraded from QGIS 2.10.1 PISA to QGIS 2.18 last week (via KyngChaos), and since then have not been able to run GRASS within QGIS - it appears not to be able to find the module.

I had a look at this related question, and I have located the processing options (screengrab below) and tried to find the correct grass folder paths for my system, however, I can just see the QGIS application in my applications folder - no further folder structure to locate the correct file?

Amending the current file paths to the suggested paths I can find (/Applications/QGIS.app/Contents/MacOS/grass or /Applications/GRASS/GRASS-7.x.app/Contents/MacOS) results in a 'Wrong value for parameter "GRASS folder" message.

Can anyone offer any advice? I am a QGIS newbie running on Mac OS Sierra.

enter image description here

  • 1) Do you want grass 6.4 or grass 7? 2) Do you have GRASS installed in your machine? – aldo_tapia Dec 1 '16 at 11:03
  • I was using GRASS fine last week prior to upgrading my QGIS version, so it was installed then - the action I have taken was to uninstall and reinstall QGIS only - I haven't uninstalled (or specifically reinstalled) GRASS. In terms of the version, I just want a version of GRASS to run properly - I'd assume I want grass 7 as this is more up to date, unless there are explicit reasons not to be running the most up to date version? – Lisa SH Dec 1 '16 at 12:12
5

I have figured this out and thought it best to post the answer for future users.

Firstly, I right clicked on my QGIS application and selected 'Show Package' to show the subfolders within the application (apologies if this is obvious to most users but it wasn't to me!)

In doing this I managed to locate the exact path of my GRASS installation, which is /Applications/QGIS.app/Contents/MacOS/grass7.

I replaced both GRASS folder locations shown in the screengrab above (within my original question) with the correct path, but only ticked 'Activate' on GRASS GIS 7 commands. (As I assume these supersede the standard GRASS commands.)

This still didn't fix the problem, however I then noticed in Plugins > GRASS > Grass Options, under the General tab there is an option to insert a custom file path to the Grass installation, so I pasted the same file path in here.

After restarting QGIS I now have working GRASS again.

  • 1
    I did try... for some reason the board won't let me for the next 18 hours?! Maybe because it's my own answer. I'll do it as soon as I'm able though for neatness on the forum. – Lisa SH Dec 2 '16 at 16:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.