I upgraded from QGIS 2.10.1 PISA to QGIS 2.18 last week (via KyngChaos), and since then have not been able to run GRASS within QGIS - it appears not to be able to find the module.

I had a look at this related question, and I have located the processing options (screengrab below) and tried to find the correct grass folder paths for my system, however, I can just see the QGIS application in my applications folder - no further folder structure to locate the correct file?

Amending the current file paths to the suggested paths I can find (/Applications/QGIS.app/Contents/MacOS/grass or /Applications/GRASS/GRASS-7.x.app/Contents/MacOS) results in a 'Wrong value for parameter "GRASS folder" message.

Can anyone offer any advice? I am a QGIS newbie running on Mac OS Sierra.

enter image description here

  • 1) Do you want grass 6.4 or grass 7? 2) Do you have GRASS installed in your machine?
    – aldo_tapia
    Commented Dec 1, 2016 at 11:03
  • I was using GRASS fine last week prior to upgrading my QGIS version, so it was installed then - the action I have taken was to uninstall and reinstall QGIS only - I haven't uninstalled (or specifically reinstalled) GRASS. In terms of the version, I just want a version of GRASS to run properly - I'd assume I want grass 7 as this is more up to date, unless there are explicit reasons not to be running the most up to date version?
    – lisagravy
    Commented Dec 1, 2016 at 12:12

2 Answers 2


I have figured this out and thought it best to post the answer for future users.

Firstly, I right clicked on my QGIS application and selected 'Show Package' to show the subfolders within the application (apologies if this is obvious to most users but it wasn't to me!)

In doing this I managed to locate the exact path of my GRASS installation, which is /Applications/QGIS.app/Contents/MacOS/grass7.

I replaced both GRASS folder locations shown in the screengrab above (within my original question) with the correct path, but only ticked 'Activate' on GRASS GIS 7 commands. (As I assume these supersede the standard GRASS commands.)

This still didn't fix the problem, however I then noticed in Plugins > GRASS > Grass Options, under the General tab there is an option to insert a custom file path to the Grass installation, so I pasted the same file path in here.

After restarting QGIS I now have working GRASS again.

  • 1
    I did try... for some reason the board won't let me for the next 18 hours?! Maybe because it's my own answer. I'll do it as soon as I'm able though for neatness on the forum.
    – lisagravy
    Commented Dec 2, 2016 at 16:15
  • This method worked for me with QGIS 3.16.0 installed as /Applications/QGIS.app which has GRASS in the /Applications/QGIS.app/Contents/Resources/grass78/ directory -- Setting Plugins/GRASS/GRASS Options/General/Grass Installation/Custom/ to /Applications/QGIS.app/Contents/Resources/grass78 and restarting made Plugins/GRASS/GRASS Options/General/Grass Installation/Default/ have /Applications/QGIS.app/Contents/Resources/grass78 and it works. /// I found the directory in a Terminal window with ls /Applications/QGIS.app/Contents/Resources/
    – Dave X
    Commented Dec 8, 2020 at 23:15

I had the same issue. There was an error with the path. I have QGIS 3.14, and a Mac running on Mac OS 10.15.4 Catalina. The path for grass was /Applications/QGIS3.12.app/Contents/Resources/grass7.

I went in the Settings >> Options >> Processing >> Providers >> Grass and I wrote the new path with QGIS 3.14 instead of 3.12. Wrote the same path in the grass plugin (Plugin >> Grass >> Grass Options >> General >> Custom) enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.