1

I am running ArcGIS Desktop 10.4.1 with a basic license and I am working on a community plan for a first nations community. We contracted a company to do some aerial photography of the area. The images they provided to us are in multiple formats, all displaying the same information (*.IMD, *.TIF, *.TIL, *.JPG). I have been working with the *.TIF versions of the files because they have the greatest detail. Our study area required them to provide us with 3 separate images to span the entirety of the area.

The issue that I am having is the 'black space' or what I assume to be no data due to the clipping that this company performed on the data is creating visual slivers when displaying due to the overlapping nature of the three images.

To confirm that the black space is in fact 'no data' I need an attrubute table. From what I have read online, it appears that I need to flatten the raster (currently 3 bands) to a single band to be used in the build raster attribute table tool. From ESRI support (Article ID: 000009462) it states to use the copy raster tool followed by the build raster attribute table. I was able to do this, the tool ran successfully but was unsuccessful in flattening the raster to a single band, it remains in three bands (RGB), not allowing me to build an attribute table.

Will flattening and building an attribute table for the raster allow for me to remove these 'no data' values so I can display these images without slivers as they are to be used in meetings and final reports?

If so, what would be the steps/tools needed to make this happen?

If not, I would like a definite answer if this is at all possible, I have scoured the interwebs for answers and many people appear to have similar issues with no definite answers.

It is important to note that I have reviewed steps to make this happen using the greyscale function in the image analysis window (which worked in flattening the raster). I need to keep colours in tact for these images, greyscale is not an option.

  • Have you gone to the properties of the raster and changed the NoData value color to transparent? – GeoSharp Dec 2 '16 at 18:11
  • YOU ARE A LIFE SAVER!!!! I knew it had to be something simple! – Husters Dec 2 '16 at 18:17
  • Don't use the tifs. You miss all the metadata including nodata. Use the imd file. apollomapping.com/blog/… youtu.be/rJcz0c31S-U – user2856 Dec 3 '16 at 7:22
1

In ArcMap, on the Symbology tab of the Layer Properties dialog you can change the NoData color of a raster. See the image below:

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.