1

When publishing a Web Map Image Layer from ArcGIS Pro where the map uses a font in the symbology, I get this warning:

20025 Layer uses fonts which are not embeddable and are not on the server

This would normally be related to the font is not installed on the server I try to publish to, and the first time I tried to publish, the font in question was not installed on the server.

But now I have installed the font on the server but I still get this warning!

I ignored this and ran the publishing anyway. It went smoothly, and in the resulting published service, the symbols are shown correctly!

So why do I still get this warning in ArcGIS Pro?

  • 1
    I guess someone has to say it, and this time someone is me: if it works, why bother? If the problem occurs again, give it another go. If not, don't loose any sleep over it :) (Although I appreciate the desire to understand the software.) – Martin Dec 7 '16 at 11:33
  • Often, the publishing prosecc takes a long time to run. I would like to know the actual issues before I start the publishing, which is kind of the point with the analyzer in the first place; to handle issues before a tedious process eventually fails... I used I long time double checking and triple checking that I had actually installed the correct font on the server, before I gived in and finally did the publish. – awe Dec 22 '16 at 9:47
1

You get this when analyzing because there is no way for the server to query for a particular font, and make that information available back to the querying software (ArcGIS Pro). As such, this is a warning only. Meaning there could be a problem. However, as you indicate, you've installed the font on the server and it works, so this warning can be safely ignored.

There are other analyzers that work in this way. I can think of a geoprocessing publishing one if your tool is powered by a DLL. The publishing process cannot copy/install the DLL. It is your (publisher) responsibility to make sure the dll (or in this case your font) is installed on the Server. However, once it's installed the Server cannot answer back to the publisher, "yes, X is installed".

  • 1
    Well, then the message text is wrong, as it says "... and are not on the server". If it is meant as a warning, the wording here should be different. – awe Dec 22 '16 at 9:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.