1

I am in windows 7. I installed WAMPServer. Now, I can not load spatialite libraries. It is showing warning..

Warning: SQLite3::loadExtension() [sqlite3.loadextension]: Not supported in multithreaded Web servers

Here is my total configuration procedure, what I have done...

From this link I got spatialite lib. I copied "libspatialite-1.dll" and paste it to "D:\wamp\bin\php\php5.3.8\ext" which contains php extention dlls.

http://www.gaia-gis.it/spatialite-2.3.1/libspatialite-win-x86-2.3.1.zip

Then I edited php.ini file. I changed the following configuration.

.
sqlite3.extension_dir = C:\libspatialite-win-x86-2.3.1\bin
.
extension=libspatialite-1.dll
.
enable_dl = On

And lastly, I copy and paste all the libraries from my downloaded libspatialite-win-x86-2.3.1 to my project folder(libspatialite.a, libspatialite.dll.a, libspatialite.la) in my php code i write the script as follows...

<?php

$db = new SQLite3('sixcommunes.sqlite'); 

$db->loadExtension('libspatialite.a'); 

$rs = $db->query('SELECT spatialite_version()');
while($row = $rs->fetchArray()){
    print "<h3>SQLite version: $row[0]</h3>";
}

?>

I do not know what I have done wrong or how to solve this problem?

  • This is more of an Apache issue than a GIS issue. Have you tried stackoverflow? You might get more luck there. – Mr_Chimp Mar 21 '12 at 14:27
  • Thanks for your help. I have already done that, already. – Shahjalal Mar 21 '12 at 22:29
1

Did you ever get this resolved? If not, try replacing the .a suffix with .dll. You can't load an archive (.a) in place of a shared library (.dll).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.