3

Lately I updated from QGIS 2.14 (LTS) to 2.18 on Mac OS X. Since then, the QSpatiaLite plugin has ceased to work, yielding following error message: Error message after clicking on the QSpatiaLite button

I have tried the following to repair the problem, without success:

  1. Removing the SpatiaLite DB from the DB Manager Plugin and re-adding it. I am then normally prompted by SpatiaLite to create a new DB, however SpatiaLite can't connect to it, I get the following two errors:

First error messageSecond error message

  1. Reinstalling QGIS 2.14 with all package dependencies from http://www.kyngchaos.com/software/qgis
  2. Installing QGIS from brew as

    brew install osgeo/osgeo4mac/qgis-lts

  3. Removing all QGIS files with terminal, like:

    sudo rm -R /Library/Frameworks/SQLite3.framework/ sudo rm -R /Library/Frameworks/GEOS.framework/ sudo rm -R /Library/Frameworks/GDAL.framework/ sudo rm -R /Users/[myusername]/.qgis2 sudo rm -R /Applications/QGIS.app/

1 Answer 1

1

QSpatialite uses Pyspatialite and there is a path problem in the Kyng Chaos SQLite installer, look at Mac QGIS 2.14: error loading module “processing”. No module named pyspatialite [duplicate] and Pyspatialite installation error on MacOSX (QGIS plugin)

1
  • 1
    Thank you for your help, but I've verified it and the paths are consistent
    – Cyril
    Dec 9, 2016 at 13:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.