1

When I open QGIS, this message shows:

Semi-Automatic Classification Plugin: Please, restart QGIS for executing the Semi-Automatic Classification Plugin. Possible missing dependecies: SciPy

When I try to reinstall or uninstall the plug in, or even only click on it, it always crashes. I have already reinstalled QGIS but didn't help. I have OS X 10.8.5 and QGIS 2.14.8

I have to do a land cover change analysis for a project and wanted to use NDVI, I had all my hopes on this plug in.

  • Sorry, I am new to this, thanks for your help! Why do I need scipy? I thought when I downloaded QGIS, that the package is complete, and then I can add plugins as needed? – rosi Dec 11 '16 at 21:41
  • Do you have to install more than GQIS and SCP to use SCP? – rosi Dec 11 '16 at 21:52
  • Hi I have the same issue when trying to install the semi automatic pluging. I did install al the required plugins from source and I also tried through the terminal but it continues to crash and this appears:Check Python Numpy, Scipy, and Matplotlib installation for the Semi-Automatic Classification Plugin. I'm desperate. Any help? – Yan Bensamoun Apr 4 at 16:21
  • This does not really answer the question. If you have a different question, you can ask it by clicking Ask Question. You can also add a bounty to draw more attention to this question once you have enough reputation. - From Review – Vince Apr 4 at 16:48
3

I suggest you read the documentation. Your error message states - "Possible missing dependencies: SciPy"

The SCP installation notes for Mac state:

In addition, download and install the python modules Numpy, Scipy, and Matplotlib

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.