3

I'm looking for some assistance and like many here, I am pretty much a GIS novice.

I'm working on a project to map our local cemetery (about 40 acres), locating sections, lots, and graves, etc.

I was able to obtain an aerial photo of the cemetery and, using a series of about 6 reasonably accurate GPS waypoints, create a georeferenced TIFF using QGIS and GDAL. This seems to have worked fairly well. Imported as a layer into QGIS, it overlays the Google imagery from the Open Layers plugin well enough for my current use.

Since I have a little more drawing control, I've been trying to use AutoCAD map for creating the features (call this the “master.dwg”). I imported the TIFF file and drew a few features based on the TIFF image. Exported them to shapefiles, opened in QGIS and this looked pretty good as well (with the previous TIFF and OpenLayers shown).

My next step was to create a layout of one of the sections in AutoCAD map. I created a drawing using architectural units so I could enter values as 25’ 6”, etc. Once I completed the layout, I tried inserting the section into the master.dwg. For some reason, the scales seem to be massively out of whack. Basically, the inserted section is probably hundreds of times larger than the georeferenced TIFF. The large dimension of the section is only about 200 feet, yet when zoomed to extents, the TIFF file doesn't even appear. It is necessary to zoom in quite a bit before it even appears as point in the drawing.

Using the measure tool in AutoCAD, measuring the distance between two known points on the TIFF literally registers a Zero (I would have expected it to be about 200 ft). In QGIS, it measures about as expected.

Any thoughts as to what is happening here? I'm at a loss right now.

===================================================

I've made a little progress. Today, I was able to get some shapefiles from our local GIS dept. of the area around the cemetery. I've tried MAPCONNECT and MAPIMPORT with the same results... I create a new drawing, assign the projection (MI83-SIF) and then attach / import the shapefiles. Units for the drawing are standard decimal. Using the MEASUREGEOM, I measure between two points and get 204 (which is what I would expect in feet). When I change the units to Architectural, then MEASUREGEOM returns just over 17'. So, it appears that, while "204" in the shapefile should be feet, AutoCAD Map is interpreting it as inches.

  • does the distance show up as zero in the master.dwg before inserting the second drawing? Is the second drawing really required? Wouldn't it be better to create layout in the master itself? – vinayan Mar 22 '12 at 4:00
  • The second drawing probably isn't required, but I had started creating the graves & lots before I had the "master" setup. – Matt Mar 22 '12 at 22:30
1

After drawing with arch units you can switch back to engineering.
Then you need to assign the coord sys in map.
After which upon insert of your tiff be sure to use the Map image insert (not the normal insert pulldown) and double check that the units is not inches

0

This is a normal behaviour in AutoCAD as far as i know. Since you are digitizing over the tiff in AutoCAD using Map>Tools>Import, your output(if you export as shape) will be in correct dimension. If your idea is to add dimensions to the drawing, and printing the layout, the the below strategy could be useful. I am assuming the you want to use the shapefile as the final output.

  1. Continue digitizing in standard decimal units. Remember that if you enter 60 distance in the command line, it means 60 feet.
  2. Before dimensioning, Change the Dimension units(see figure below) to architechtural and multiply the scale factor by 12.

enter image description here

Note:

Never scale the drawing by 12 units so it will display the correct measurements in CAD, as this will not export in proper dimensions as a shape file. If you do not want to use shapes any more you can go ahead and scale entire drawing by 12 units and change units to Architectural.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.