4

This question already has an answer here:

I made a map including 3 levels of zoom as shown in the screenshot. The problem is that whenever I save the map to a PDF, the layout of these maps is changed seemingly random. In the lower left image, the purple region appears in the sea

This is how the map is supposed to look. Only difference is I saved the file another name. Usually, the image becomes even more distorted, but hopefully you get the idea.

I have a hunch that it has to do something with 'Lock layers' or 'Lock styles for layers' functions, but they don't really seem to work. Right now, I have the lock layers box checked on all maps and Lock styles for layers unchecked.

marked as duplicate by underdark qgis Dec 13 '16 at 21:44

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 3
    OpenLayers plugin? – Nathan W Dec 12 '16 at 23:58
3

You have to start from the first map by activating the layers you want to make visibile; once this is done, check Lock layer and Lock styles for layers option and then pass to the next map. Finally, try using the Refresh button before saving to PDF, so you can see the map being saved:

enter image description here

Or maybe, as @Nathan W correctly says, it could be due to the using of the OpenLayers plugin: try using QuickMapServices plugin instead of it.

  • 1
    Thank you very much, the problem was indeed the OpenLayers plugin! – JLangemeijer Dec 14 '16 at 17:17

Not the answer you're looking for? Browse other questions tagged or ask your own question.