1

I'm having trouble printing maps to PDF using MapInfo Professional 12.0.1 at work.

The error on the PDF is: An error exists on the page

I am using File -> Print to PDF -> MapInfo PDF Printer Version 12.0. The PDF needs to be a layered PDF due to the amount of information, but also add the attribute data - I believe these two options are causing the problem? Maps have exported to PDF in the past when these options are not ticked.

Regarding the print settings, I have enabled the options I found online which are meant to fix the issue (enabled postscript simulation, multi-language support, font embedding, tried multiple compressions to reduce image size including 72DPI)

Is there something I am missing to get this to work? What is annoying is the exact same settings worked on a trial export at A3, but not now (only added a legend in).

3
  • 1
    Does this happen with certain data? Can you narrow it down to particular layers/features? As is, this isn't reproducible and it's not likely that you'll get a good answer here. Dec 15 '16 at 19:37
  • Another thing to consider is how much data you're trying to include as attributes. PDF was designed as a way to present documents not as a database/GIS system and as such will have some limitations as to the amount of data it can reliably handle. You may want to either reconsider the format or try and include less data.
    – T_Bacon
    Dec 16 '16 at 8:51
  • To add to @T_Bacon's statement: MapInfo Pro will bring over the attributes from all the selectable layers. Make sure only the necessary layers are selectable Dec 16 '16 at 9:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.