1

Im having an Issue with my Split Line at Point tool. Seems to run if lucky for 700 entries before arcmap/arccatalog falls over. Debugging of the errorlog has produced nothing. The total size of the line layer is 400,000 and the point layer 450000 covering the size of most states.

Is there anyway I could set a python script to pull a row from current mxd, run the split line to point, to the point layer held in ram then append it to a shape/fgdb file, then loop back until complete.

I have tried the various logical issues of confirming projections the same, repairing geometry, even splitting the data into 10% chunks/FCs. Also tried FME to the same result that it appears to run out of memory.

Cheers.

EDIT> At the moment Im tilling using Iteration by rowid using a dummy field that is populated with suburb names (spatial join population). This keeps the rows selected under 2000 each pass and at this stage seems to be working. 26/03/2012

  • According to your problem description this might seem more like a general problem of the 32 bit constraints of arcgis. cant judge for FME though. – maxwhere Oct 5 '17 at 3:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.