I'm really confused by this. ArcMap will seeminly randomly decide to not allow snapping when editing. Sometimes its only for certain features, sometimes for only parts of the same feature (e.g. one end of a line but not the other, or not along a part of the line). Now its just flat out not letting me snap to anything (yes, snapping is turned on with all options on). Any hints on this one?

  • I get this too. My workaround is to click on a different tool in the editing menu then click back to the tool I was using which seems to bring the snapping environment back to life. Mar 23, 2012 at 15:49
  • I've discovered that the feature will snap to other features at the X at the center of the feature. You can move that X by holding down the Shift key while you're using the Edit Tool, where it can snap to vertices or edges.
    – kenbuja
    Mar 23, 2012 at 16:02
  • 1
    It seems to me that the lack of snapping can be associated with certain MXD files - I just rebooted and still couldn't snap, yet took the same features into a new MXD and the snapping worked. so there must be features in the original MXD that aren't compatible with snapping, or maybe it is just a bug.
    – Ian
    Apr 20, 2012 at 5:20
  • Snapping wasn't working when I was editing in an MXD I received from a colleague. I was able to resolve my issue by clicking the drop-down in the Editor Toolbar, selecting Options, opening the General tab, and unchecking Use Classic Snapping.
    – Ray
    Jul 8, 2016 at 17:25

11 Answers 11


There are several steps I use.

  1. Ensure you are Data View NOT in Layout View (thanks MW)
  2. is easiest but don't necessarily try it second. copy the layer you need to edit, snap to and use for reference (as few as possible) to another document (for editing).
  3. make sure you don't have a definition query.
  • +1, excepting ensuring not in Layout View should be first step (easiest to test). Nov 19, 2014 at 18:13

I discovered that snapping won't work if the layer you're editing is in the Map Document more than once.


What Brad said (especially make sure you're in data view - focus your data frame or edit in data view rather than layout).

You can also tighten your snapping tolerance. Under the snapping drop down arrow, select "options". Change the number value shown in my printscreen below. Sometimes this works for me. I've seen instances where this seems to refresh my snapping capability. Usually, I just don't have my data frame focussed though.

enter image description here

  • absolutely this is the solution. re-activate your data frame (even if you are not in layout view). I will try the tolerance test next time it goes away. +1
    – Brad Nesom
    Aug 14, 2013 at 17:21

I had the same issue, but a friend said that I should use classic snapping to help select the layers I wanted to snap to. The classic snapping was a simple work around to the issue.


I just usually quit the map I am working on, and then restart it and it typically works again.

What I have noticed is it has trouble when the mxd has too many layers or grouped layers. I have not checked but I wonder is the cache being to full or needing a purge may help.


I had this "no snapping" problem, and the eternal blue circle pause when trying to edit. I had a huge file of contours on my map which were in a different projection than the map. I got the warning whenever I turned on editing, but I just ignored it. When I turned off the contours, suddenly snapping and editing worked fine!

  • I think that this is a different issue. Your symptom is ArcMap working hard to figure out all possible things that can be snapped to whereas the question makes no mention of the working indicator being visible.
    – PolyGeo
    Jul 2, 2015 at 21:36
  • Actually this very well could have, at times, been causing the issue being experienced as asked in the original question. If it seems to be happening pretty randomly, they may be layers, such as contours or roads, stored on a remote server or network drive that could be having connectivity issues. Layers like this may never snap, or randomly choose not to snap. Or, there may be too many layers turned on, as PolyGeo alluded to. Picking and choosing which layers to turn on/off is certainly a viable workaround if network connectivity is causing your snapping issues. Dec 11, 2017 at 22:18

I was able to resolve this issue by doing the following: From the Editor Window --> Snapping --> Snapping Window and set the Snapping Environment. I was able to snap my vertices to the specified layer this way.


Uncheck "Use classic snapping" in the Editing Options of the Editor Toolbar. This will allow you to use the Snapping Toolbar


An MXD that snapped yesterday might not snap today. That is why I sometimes revert to Classic Snapping.

Mike's simple answer (for which he was chided) provided the best clue for my problem today. I didn't want to remove occurrences of my line data because the symbology varied. So, I tried moving the layer I was editing higher in the Table of Contents and classic snapping worked.

Try this to see if the layer you are snapping to is recognized by ArcMap. Use Classic Snapping. Then open the Snapping Window to see if that layer is listed. If not, move it higher in the TOC.


I had an issue where the editor would not even select a certain point feature. I would have to select it with the "Select Feature" tool and then it could be moved but it would still not snap to the line feature.

Not sure why this worked but I turned on a different point feature and was able to select it with the editor and could snap it. When I went back to the orginial feature I wanted to snap it worked.


I had the same issue, and the only solution that I found was to only select the specific snap one at a time, for example, only activate "end point snap" and deactivate the others, I hope this works.

Not the answer you're looking for? Browse other questions tagged or ask your own question.