3

I have created a vector which is a connection to Sql Server. I then select Vector > Geometry Tools > Voronoi Polygons. I select my input layer and a temporary file for my Voronoi polygons. I get the float division by zero error and the file is empty that is supposed to be created. I am new to QGIS and am baffled as to what I am doing wrong. I have used the Check Validity menu item and the geometry in the input layer is valid. Also where do I get to select the grouping for my input data for the polygons generated ?. Any ideas anyone?

I should add that I get the same error for Delaunay triangulation algorithm. There is something I am missing but I an unaware of what it is.

2

Not sure what version of QGIS you're using, but if it's 2.18 there appears to be a known issue which is fairly recent.

It happens when no polygons are created, so the fixed version will just give you a different, more informative error message.

You should check you're doing this on a points layer. I managed to get the same if I load in a shapefile of type polygon. Normally the dialog only allows you to select point layers, but allows you to open other files using the ... button.

  • Yeah I am using 2.18 but I am about to change to an earlier version. I do need a more informative error message. – Darren Wood Dec 21 '16 at 20:12
  • 1
    is it a points layer? if not, i suspect reverting to an older version won't help. If it is a points layer, something else might be the problem. – Steven Kay Dec 21 '16 at 20:20
  • It is a points layer – Darren Wood Dec 21 '16 at 20:26
  • It is failing as well. Slightly different in that it just hangs and never creates the result. I can not see where the error is defined though. – Darren Wood Dec 21 '16 at 20:52
  • 1
    The reason it was failing is because it was a multipoint event though it was only 1 point. I forgot I had to change this when I was extracting it elsewhere. So it works now thanks for your help. – Darren Wood Dec 21 '16 at 22:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.