1

Have iMac with OS 10.7.5. This is the first time I am installing QGIS. Everything was downloaded from kyngchaos.

This is what I did in that order: Downloaded QGIS-2.12.0-1. Tried to install. It asked for GDAL 1.11. Got GDAL_complete 1.11(EB). Installed. Next QGIS asked for matplotlib. Got matplotlib-1.4.3. Installed. Next QGIS asked for PROJ_framework 4.9. Got PROJ_Framework-4.9.2-2. Installed. Next QGIS asked for SQLite3_Framework. Downloaded SQLite3_Framework-3.8.7.3-1. Installed. At this point QGIS installed.

When I click on Q in applications, it says 'QGIS quit unexpectedly'. ERROR:EXC_BAD_ACCESS (SIGSEGV)

Clearly something is not as it should be. What do I need to do?

1

If you go to the KyngChaos archive

enter image description here

Yon can see that GDAL 1.11.1, PROJ 4.9, GEOS 3.4.2, SQLite3 3.7.17, UnixImageIO 1.5.0 are included in the GDAL complete Framework, therefore you don't need to download the individual Frameworks

The order to install QGIS is:

  1. install the GDAL Complete 1.11EB Framework

enter image description here

Content of the GDAL complete framework (with Pacifist)

enter image description here

The frameworks are installed in (control with Suspicious Package)

enter image description here

  1. Install the KyngChaos matplotlib and Numpy Python module

The Python modules are installed in

enter image description here

  1. Launch QGIS

Now, if you want to upgrade the individual Frameworks, you can download and install them individually

The best solution for you is to delete all the installed Frameworks and reinstall all following the procedure.

  • 1
    I ran this precise package from the Kyngchaos site - GDAL_complete1.11EB. I also installed Numpy from this package. QGIS still asked for all the others in that order. They were all installed in the Frameworks and Python folders you have indicated, properly. QGIS still does not launch. I am not upgrading anything at all, just installing the basic software for the first time. – SRath Dec 26 '16 at 13:20
  • 1
    In fact, QGIS asks for SQLite_Framework 3.8 or later specifically. I downloaded 8.7.3-1 and installed. The 3.7.17 is not working. – SRath Dec 26 '16 at 13:33
  • 1
    QGIS also asks for PROJ framework 4.9, again specifically. So I installed 4.9.2-2. – SRath Dec 26 '16 at 13:36
  • 1
    There is a mismatch between what QGIS 2.12.0-1 requires and what is listed in GDAL complete 1.11EB. Sorry, I mistyped earlier. Installed SQLite 3.8.7.3-1. – SRath Dec 26 '16 at 13:42
  • 1
    GDAL complete 1.11EB is most definitely not installing the PROJ and SQLite frameworks on its own. – SRath Dec 26 '16 at 13:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.