Is it possible to use Python 2.6 (or 2.7?) with ArcGIS 9.3?

The official stance is no, not supported. There are a number of reports in the wild though that it can be done. How is this accomplished? and is there anything to watch out for?

2 Answers 2


In all ArcGIS 9 versions you can upgrade python to the latest and greatest version with a few simple steps. Here's the recipe for 9.3 and 2.6:

  • Install python 2.6, and the latest corresponding pywin32.
  • Grab the arcgisscripting.py script written by Philippe Le Grand (see this thread in the ESRI scripting forum) and plop it into C:\Python2.6\Lib\site-packages
  • Make sure PYTHONPATH environment variable points to C:\path\to\ArcGIS\bin

This is an unsupported configuration, see ESRI knowledgebase article 31912.

Recipe from http://www.yukongis.ca/How_To/Upgrading_ArcGIS_Python


Do you have any compelling reason to upgrade beyond 'because I want to?' Most popular third-party Python libraries are available for 2.5 and there's no point in risking major compatibility issues. arcgisscripting should fail and throw with an error like "use of python25.DLL conflicts with this version of Python" when importing a 9.3.X arcgisscripting in Python 2.6 or beyond.

  • The main impetus is that my text editor / IDE of choice, leo-editor, requires 2.6+. I've not encountered the dll conflict message and I've been upgrading beyond the ESRI shipped python since py2.1 (using the recipe in the other answer). However it should be noted I only use a small subset of the geoprocessing tools and there may well be incompatibilities yet to be uncovered. Commented Sep 28, 2010 at 16:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.