2

I want to install QGIS on an iMac OSX 10.7.5. According to the KyngChaos archive, I have to use QGIS 2.12.0-1, with GDAL_complete-1.11EB, matplotlib and Numpy. This is what I am trying to do, unsuccessfully.

I did installation in the following order: I installed GDAL 1.11EB. This put GDAL, GEOS, SQLite, PROJ frameworks in Frameworks folder in Library. Then installed Numpy (I have tried the one in the GDAL1.11EB package and 1.9.2-1). Then installed matplotlib (I have tried both 1.3 and 1.4.3). Had no trouble with any of these and both the Frameworks and Python 2.7 directories were populated correctly.

However, after this, when I tried to finish installing QGIS, QGIS 2.12.0-1 fails to install unless I install SQLite framework 3.8, for which it needs PROJ framework 4.9. QGIS 2.12.0-1 installs only if I install these on top of the earlier GDAL 1.11EB. But then it does not launch. Simply 'quits unexpectedly'.

What I understand from this process is that, there is a mismatch between what QGIS 2.12.0-1 is expecting to see regarding the SQLite and PROJ frameworks, and what is contained in GDAL-1.11EB. Simply installing the frameworks it wants to see is obviously not enough to get it to work.

How do I resolve this?

I hope this clarifies my problem. It really is only about how to install the basic QGIS 2.12.0-1 on a Mac OS 10.7.5 successfully.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.