1

I found that tile map of each region in geoserver2.9.2 of platform independent binary displays its name two or more times. As shown in the first picture.

I have done as How to avoid duplicate labels on each tile? [duplicate] and Polygon label repeated for each tile. However, some areas of label in sixth and seventh level do not show and some appear offsets. As shown in the second picture.

Here's my code:

<TextSymbolizer>
 <Geometry>
  <ogc:Function name="centroid">
     <ogc:PropertyName>the_geom</ogc:PropertyName>
  </ogc:Function>
 </Geometry>
</TextSymbolizer>

And then I have done as Labels on tiled map sometimes unavailable. It was same as above in seventh level.

Here's my code:

<VendorOption name="partials">true</VendorOption>

I have no idea how to modify it. Can anybody tell me?

enter image description here

enter image description here

5
  • 1
    This questions looks somewhat familiar....
    – BradHards
    Dec 28, 2016 at 21:14
  • What version of geoserver are you using?
    – BradHards
    Dec 28, 2016 at 21:15
  • The version of geoserver is 2.9.2 of platform independent binary. I asked this question a few days ago. And someone gave me a similar problem of links, which did not solve my problem.
    – Epulari
    Dec 29, 2016 at 1:38
  • Do you got the CSS Plugin? You might try recreating the style with CSS. Dec 29, 2016 at 10:09
  • I closed this last time because it is a duplicate - please edit your other question if you think it isn't a duplicate.
    – Ian Turton
    Dec 29, 2016 at 11:19

0

Browse other questions tagged or ask your own question.