3

I am trying to add my database through the "add database server" so that I can add users and maintain their permissions. We are running a dbo schema and our spatial database connection is working but not the server itself. Our database is running a SQL Server 2008 full edition instead of the Express edition.

When we are prompted to enter it, we enter ourdatabasename\sqlserver2008. Is this correct?

1
  • I set up this connection last week with the Express version. It should be serverName\sqlserver2008. I think I just copied and pasted from SQL Server Management Tools.
    – Roy
    Sep 24 '12 at 19:39
1

Hmm, here's the ESRI help doc regarding 'database server' connections.

http://help.arcgis.com/en/arcgisdesktop/10.0/help/index.html#/Creating_a_geodatabase_on_a_database_server/003n00000028000000/

It only mentions SQL Server Express, so I'm going to guess that you won't be able to connect to the full version of SQL Server this way. I'd suggest adding users through SQL Server Management Studio (http://msdn.microsoft.com/en-us/library/ms174173%28v=sql.105%29.aspx) and then managing permissions per dataset within the geodatabase using the 'Privileges' command on the right click menu from the 'Database Connection' interface.

1
  • All things considered, I think it's more likely that the configuration is wrong. I'm not sure the full extent of the differences between the full version and express, but I was under the impression it had to do with data storage capacity (Express is limited to 10GB).
    – Roy
    Sep 24 '12 at 19:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.