1

I am for the moment, quite stumped. I have a layer of points to which i have retrieved values from an underlying raster. From these values, I am trying to create a TIN, using the Interpolation tool in QGIS. The tool runs with no errors, but the result is a raster of no data. I have tried:

Using QGIS 2.18 (Las Palmas de G.C:) and running Windows 10

  • Setting the regional settings to using a period and a comma for the decimal marker
  • Different tools, including IDW and squared TIN in the Interpolation dialog. This includes SAGA Trinagulation tool (this returns an error - tool not found)
  • Different projections for the points and the raster
  • Opening the points and running the analysis in a separate project
  • Changing the directories to avoid spacces in directory names
  • Changing the output file type (.asc and .tif)
  • Running the interpolation in an older version of QGIS (2.8)

Nothing has worked so far. The only diference was using squared TIN, that produced values of 0 instead of No data.

EDIT: here's a screencap showing the points and a sample of the attribute table. Second column is the data used, it's the same as the first with negative nubmers set to 0.

Point data

Any ideas?

closed as unclear what you're asking by user30184, Andre Silva, whyzar, Kersten, Mapperz Jan 5 '17 at 15:12

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    Impossible to answer without seeing the point data that you have. – user30184 Jan 5 '17 at 11:18
  • @Sampi I'm trying to reason why one might want to produce a TIN in this way when there are generally more tools and workflows available (or at least comparable) for rasters. I've used workflows pulling out raster values to points too, but this is only when the points were the end game. There are better ways to resample or dump resolution in the original raster, if that's what's needed. Also, I wouldn't recommend mismatching projections. – Priscilla Jan 6 '17 at 15:44
  • I made a simple test by digitizing 4 points with attribute "syvyys" varying between 80.1m and 80.4. Running interpolation with QGIS 2.16 by using the TIN method worked as supposed. I used the default output size and "Set to current extent". You must add more details into your question. – user30184 Jan 7 '17 at 12:54
  • @Priscilla: thanks, you're right that dumping resolution or resampling would be more efficient in another manner, but that's not what I'm after. I'm extracting values to create a wholly different raster, which is dependent on the specific points I'm using. I'ts a method under development. – Sampi Jan 8 '17 at 17:41
  • @user 30184: sure, I'll add more detail. What is it you need to know? – Sampi Jan 8 '17 at 17:45