2

I am trying to use the GDAL module in QGIS to convert some NetCDF files into GeoTiff through batch processing. Unfortunately, I keep getting the same error even after several attempts. This is the error's text body:

    2017-01-06T23:57:04 1   Traceback (most recent call last):
          File "C:/PROGRA~1/QGISLA~1/apps/qgis/./python/plugins\GdalTools\tools\widgetBatchBase.py", line 73, in onRun
            self.batchRun()
          File "C:/PROGRA~1/QGISLA~1/apps/qgis/./python/plugins\GdalTools\tools\doTranslate.py", line 306, in batchRun
            self.runItem(self.batchIndex, self.batchTotal)
          File "C:/PROGRA~1/QGISLA~1/apps/qgis/./python/plugins\GdalTools\tools\widgetBatchBase.py", line 107, in runItem
            self.base.refreshArgs(args)
        TypeError: native Qt signal is not callable

Anyone has any idea how to solve this?

N.B: I've tried this earlier in the day on a different laptop and it worked, therfore the files are not a problem.

2
  • 3
    this seems to be a known issue logged against 2.16. It looks like running it in 2.14 might be a workaround, which might explain why it worked on your other laptop.
    – Steven Kay
    Commented Jan 7, 2017 at 17:04
  • Oh, great. My worries were something has to be done in code, which I don't know. Guess I'll be switching for an older version:)
    – crisvr
    Commented Jan 7, 2017 at 21:27

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.