1

I am trying to label multiple parts of a polygon.

As this is not working, I decide to select the part not being labelled, make a new polygon of that ('sss'; magenta) and label that single part polygon (intending to make the layer invisible).

However the magenta polygon's label '18' only appears when the polygon is in edit mode and cannot be seen when the polygon is saved (although the polygon itself is still visible).

Also, I do not have 'Only draw labels which fit completely within feature' ticked.
And do have 'Show all labels for this layer' ticked.

Does any one why a label might only be visible in edit mode?

enter image description here

  • What colour is the font set to? – BillW Jan 10 '17 at 4:10
  • Does not appear regardless of colour – Amroco Jan 10 '17 at 17:00
4

You are using an older version of QGIS and I cannot tell you the exact way to solve this. I think in two things you could try. Your Artic sea label is repeated and also it may be too big to be contained with no overlaps. You may want to check one or both these options in the labeling menu similar to this one:

enter image description here

  • Unfortunately, both criteria were met. I think what is most interesting is that the label is visible when the polygon is open for editing. Usually if a label appears there, it will also appear when the polygon is saved. – Amroco Jan 10 '17 at 17:10
  • Not a solution, but something similar can happen with styles. If there is no style assigned for the uncategorised group of values, they will appear in the attribute table and various places but will not be styled on the canvas. i.e. if you haven't set a style for 0 or null values but have for 1, 2, etc then it can be a bit of logic step to realise what is going on. Perhaps you have some filter applied on this layer? – BillW Jan 12 '17 at 2:32
0

Try setting the project CRS equal to the CRS for the layer that has the labels.

  • This would probably be better as a comment than an answer, it doesn't contain much detail or even certainty about solving the problem. – Michael Stimson Apr 11 '17 at 2:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.