1

I'm novice in GeoServer/JavaScript.

My config:

Win 10 Pro x64 - Apache 2.14 - Tomcat 9 + deployed Geoserver 2.10.0

Apache Tomcat proxy

Tomcat 9 --- CORS

Geoserver --- Installed Vector Tiles plug-in ( geoserver-2.10-SNAPSHOT-vectortiles-plugin ) and WPS plug-in.

Trying to figure it out how to use Geoserver vector tiles so follow the instructions as written in Geoserver tutorial - http://docs.geoserver.org/latest/en/user/extensions/vectortiles/tutorial.html#publish-vector-tiles-in-geowebcache

Unfortunately, the result is a blank page with just Title "Mapbox Protobuf - vector tiles" and +/- zoom buttons ?!

What is the cause of that?

Perhaps it isn't working because Geoserver is deployed in Tomcat.

Update:

Screenshot of GEOTOOLS_DEVELOPER_LOGGING log - http://i68.tinypic.com/waiqzm.jpg

Noticed in log that BaseURL = localhost:8080/geoserver/ ,but my Geoserver is located at localhost:82/geoserver/ (!)

Maybe that's the cause??

UPDATE #2

-- regenerate tiles just in EPSG:4326 --

GEOTOOLS_DEVELOPER_LOGGING log

Request: getMap
Time = []
Filter = null
Format = application/x-protobuf;type=mapbox-vector
Buffer = 0
SRS = EPSG:4326
ScaleMethod = null
Exceptions = SE_XML
StyleBody = null
StyleVersion = null
SldVersion = null
Filters = null
Styles = [StyleImpl[ name=polygon]]
Layers = [org.geoserver.wms.MapLayerInfo@ef7f0020]
MaxFeatures = null
BgColor = java.awt.Color[r=255,g=255,b=255]
FeatureVersion = null
Transparent = true
StyleFormat = sld
Sld = null
StyleUrl = null
SldBody = null
TilesOrigin = null
ValidateSchema = false
Interpolations = []
Height = 256
Width = 256
Tiled = false
Palette = null
Bbox = SRSEnvelope[-180.0 : -90.0, 0.0 : 90.0]
RemoteOwsURL = null
Crs = GEOGCS["WGS 84", 

DATUM["World Geodetic System 1984",

SPHEROID["WGS 84", 6378137.0, 298.257223563, AUTHORITY["EPSG","7030"]], 

AUTHORITY["EPSG","6326"]], 

PRIMEM["Greenwich", 0.0, AUTHORITY["EPSG","8901"]],

UNIT["degree", 0.017453292519943295],

AXIS["Geodetic longitude", EAST],

AXIS["Geodetic latitude", NORTH],

AUTHORITY["EPSG","4326"]]

FormatOptions = {}

FeatureId = null

ViewParams = null

Elevation = []

StartIndex = null

Env = {}

Angle = 0.0

RemoteOwsType = null

CQLFilter = null

Version = 1.1.1

BaseUrl = http://localhost:8080/geoserver/

Request = GetMap

Get = true

RequestCharset = UTF-8

RawKvp = {FORMAT=application/x-protobuf;type=mapbox-vector, STYLES=polygon, WIDTH=256, HEIGHT=256, LAYERS=opengeo:countries, EXCEPTIONS=SE_XML, GWC_SEED_INTERCEPT=true, REQUEST=GetMap, SRS=EPSG:4326, BBOX=-180.0,0.0,-90.0,90.0, VERSION=1.1.1, SERVICE=WMS, TRANSPARENT=true}

2017-01-13 23:43:00,738 DEBUG [org.geotools.data.shapefile] - Read lock: file:/D:/GEOSERVER_DATA/data/ne_110m_admin_0_countries/ne_110m_admin_0_countries.shp by org.geotools.data.shapefile.shp.ShapefileReader

2017-01-13 23:43:00,738 TRACE [org.geotools.data.shapefile] - Shapefile Reader has been closed. Number open: 0

2017-01-13 23:43:00,738 DEBUG [org.geotools.data.shapefile] - Read lock: file:/D:/GEOSERVER_DATA/data/ne_110m_admin_0_countries/ne_110m_admin_0_countries.dbf by org.geotools.data.shapefile.dbf.IndexedDbaseFileReader

2017-01-13 23:43:00,738 TRACE [org.geotools.data.shapefile] - Dbase File Reader has been closed. Number open: 0

2017-01-13 23:43:00,738 DEBUG [org.geotools.data.shapefile] - Read lock: file:/D:/GEOSERVER_DATA/data/ne_110m_admin_0_countries/ne_110m_admin_0_countries.shx by org.geotools.data.shapefile.shp.IndexFile

2017-01-13 23:43:00,738 TRACE [org.geotools.data.shapefile] - IndexFile has been closed. Number open: 0

2017-01-13 23:43:00,741 INFO [org.geoserver.wms] -

migrated from stackoverflow.com Jan 11 '17 at 10:29

This question came from our site for professional and enthusiast programmers.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.