4

I've set up a GeoServer that can be accessed via mydomain.com/geoserver. Now I want to use the QGIS plugin GeoServer Explorer to add/edit layers, styles etc.

I log in as admin, the rest.properties are set to the standard configuration (admin can do anything).

At first, I could connect to my GeoServer and see all my workspaces, layers, styles etc. But as soon as I tried uploading a QGIS layer (a shapefile), problems began. Upload of the data seems to have worked, data store, layer and style (although the created SLD is lacking SVG symbols) are created.

But after the upload, whenever I try to connect, I'm getting this error:

Traceback (most recent call last):
  File "C:/Users/.../.qgis2/python/plugins\geoserverexplorer\gui\explorer.py", line 101, in run
    command(*params)
  File "C:/Users/.../.qgis2/python/plugins\geoserverexplorer\gui\gsexploreritems.py", line 551, in populate
    raise e
error: [Errno 10061] Es konnte keine Verbindung hergestellt werden, da der Zielcomputer die Verbindung verweigerte

(The last line is probably the translation of "No connection could be made because the target machine actively refused it").

Nonetheless, the workspaces section recognizes the existing workspaces + corresponding layers, but neither layers nor styles etc. are displayed in the tree:

geoserver explorer

The web GUI of GeoServer is working fine.

I deleted the new styles, as I thought that maybe a broken SLD could cause the problem, but the error still occurs.

I have no idea how to solve this or find out where the problem originates. Is this an issue of GeoServer or the QGIS plugin?

Edit: I tried a little more - after deleting all layers, I could connect again to GeoServer. Then I added my shapefiles over the GeoServer web GUI and it happened again!

The error seems to occur during publishing. If I add only a data store which I do not publish, everything's fine. But as soon as I publish it, I can't connect through GeoServer Explorer, although the layer preview is working...

Another piece of information: The error seems to occur after adding a style to my new layer. I took the standard polygon style and just changed the color code, so it can't be due to some special format.


Screenshots of my catalog definition settings (pretty standard):

catalog def 1 catalog def 2


Update: This plugin is driving me crazy. I added, edited & grouped some layers on the web GUI which seems to have worked: I can add the group layer as WMS on my website (with OpenLayers) and it's displayed correctly.

But now the connection via the QGIS plugin fails completely with this new error:

Traceback (most recent call last):
  File "C:/Users/../.qgis2/python/plugins\geoserverexplorer\gui\explorer.py", line 101, in run
    command(*params)
  File "C:/Users/../.qgis2/python/plugins\geoserverexplorer\gui\gsexploreritems.py", line 551, in populate
    raise e
UnicodeDecodeError: 'ascii' codec can't decode byte 0xfc in position 101: ordinal not in range(128)

closed as off-topic by Ian Turton Nov 20 '17 at 16:19

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This problem cannot or can no longer be reproduced. Changes to the system or to the asker's circumstances may have rendered the question obsolete, or the question does not include a procedure to enable potential answerers to reproduce the same symptoms. Such questions are off-topic as they are unlikely to help future readers, but editing them to include more details can lead to re-opening." – Ian Turton
If this question can be reworded to fit the rules in the help center, please edit the question.

  • is mydomain.com/geoserver https? – risail Jan 11 '17 at 14:45
  • @risail: no, it's http. – Franka Jan 11 '17 at 14:50
  • Can you post a screen shot of your Catalog definition settings? Your geoserver is refusing. Also what is the error in Geoservers debug tools? – risail Jan 11 '17 at 15:01
  • Do you mean screenshots from the plugin settings or from geoserver? And which debug tools do you mean? All I can find is a wrapper.log, which is not updated when I try to connect. – Franka Jan 11 '17 at 15:42
  • 1
    I'm still not sure, what caused this, but after trying out a thousand things, one fixed it twice: Reset the password of my user(s). I have no clue why it apparently had changed, but after resetting it, I could connect again via GeoServer Explorer. – Franka Feb 7 '17 at 14:14