3

I'm new to GRASS. We want to delineate a watershed using the LIDAR data we have our hands on. I tried to follow several procedures to do so, but despite all my efforts, I can only get it to select a single cell out of the DEM.

I'm using GRASS 7.0.5

What I've done:

  • Created the DEM using r.patch and the necessary tiles
  • Defined my work region (g.region)
  • r.patch the DEM to fix the bridges
  • Used r.watershed to create the Accumulation and Drainage direction layers (tried with 0, 5k and 50k thresholds)
  • Used the Drainage layer to r.water.outlet

While I eventually get a result, it is only a single pixel, although I made sure to be very (VERY) precise (5 digits precise...) on the stream coordinates. Picture of the output.

enter image description here

I believe part of the problem is that my DEM is huge... but I find it hard to believe that I'm the only one using this kind of data.

Any thoughts?

  • 1
    What is the diagonal line in the image above? Note that the outlet coordinates for r.water.outlet must be on the stream network created by r.watershed. – Micha Jan 12 '17 at 21:54
  • The line (diagonal) is my stream network, but my vector layer. I indeed made the mistake of not using the stream generated by r.watershed. I'll give it a try and come back with the results, thanks! – Horizen Jan 12 '17 at 22:21
3

As mentionned by Micha, my problem was that I was using my original stream vector layer instead of the one generated by r.watershed.

So to be clear: - With r.watershed, create both Drainage direction and Stream (at least) - With r.water.outlet, use the Stream raster layer generated this way to pinpoint precisely your outlet and the Drainage direction layer as raster input for computation

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.