2

I have an area, which I divided into voronoi polygons using data points. I have no problem creating the polygons.

Now the data points are on a coordinate system, where every degree represents one meter. I know try to use the $area command to get the area, but the answer is way to large.

To clarify my problem I will try to give a bit of an example:

enter image description here

This image gives the spatial division of a set of data points, boreholes in this case. They all influence a certain area. This area is defined as their voronoi cell. I have created these cells:

enter image description here

What I now want to know is the area of the polygons. I have tried to use the command $area, but this gives an area which is way too big. I know this because I did some basic area calculations on some of the simpeler polygons. For example the area for the triangular polygon in the bottom left (BH1101) I calculated to be about 695,000 m2. However using the $area command give me an area of 8.6140950578267e+15 which is in no unit I know equal to what I calculated.

Why is this and how can I fix this?

The data comes from an excel sheet which I converted into a .txt file and put into Qgis. The location is somewhere in Germany, if need be I can get a more precise location, but it shouldnt matter for the results. I run Qgis on the standard settings, using the CRS (WGS84:4326).

  • which CRS are you using (project, input points and output? – Jeremy Jan 12 '17 at 16:20
  • Welcome to GIS SE! As a new user please take the tour to learn more about our focused Question and Answer format. Please edit your question to include more information about your CRS and the data you are working with, as well as a sample of your data - the polygons, the areas, what you think the area should be (and how you calculated that) – Midavalo Jan 12 '17 at 16:57
  • 2
    Right-click your polygon layer, go to Save As..., assign a new CRS (try EPSG:25832 which is UTM zone 32N) and save it as a new shapefile. Load this back into QGIS, change the project CRS also to EPSG:25832 then try running $area in the field calculator again to see if the results are closer to what you are expecting. – Joseph Jan 13 '17 at 11:36
  • You are using a CRS which does not apply to the region you are working with. This of course, gives a lot of errors when calculating/measuring areas. Use the correct CRS for you area. – Konan Pruiksma Jan 17 '17 at 14:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.