3

How can I change the port GeoServer is running on from 8082 (in OSGeo Live VMs) to 80?

There is a related question here in GIS.SE., but the answers were about changing the underlying tomcat port from 8080 to 80 in /etc/tomcat*/server.xml.

Apparently, the above solution is based on assuming tomcat and GeoServer to run on the same port. But in OSGeoLive 10 VM, the tomcat port (8080) is different from the GeoSever port (8082). Also related is the SO answer here about how to change tomcat port to 80.

By the way, I am using OSGeoLive 10, with apache on 80 (??), tomcat8 on 8080, and GeoServer on 8082.

I am also confused about the relationship between apache, tomcat and GeoServer. Wouldn't changing the tomcat port to 80 cause conflicts with apache? Why are GeoSever running in different ports with tomcat and apache?

-- EDIT --

To clarify, I'd like to avoid using proxies and port forwarding if possible, as I remember having issues with them, e.g. here and about CORS. (It's most likely that I didn't fully understand proxy right).

Also, I need to be consistent between my GeoSever installation on 8082, and someone else's installation on port 80. The target server that I am trying to match does not seem to have a2enmod, libapache2-mod-jk installed (by checking apt-get). It seems to be a minimal installation and its /etc/tomcat7/server.xml is as listed below.

Any pointers on how I can match the settings of the target server? What other configurations files (if any) should I look into to mimic the target?

<?xml version='1.0' encoding='utf-8'?>
<!--...
-->
<!-- Note:  A "Server" is not itself a "Container", so you may not
     define subcomponents such as "Valves" at this level.
     Documentation at /docs/config/server.html
 -->
<Server port="8005" shutdown="SHUTDOWN">
  <Listener className="org.apache.catalina.startup.VersionLoggerListener" />
  <!-- Security listener. Documentation at /docs/config/listeners.html
  <Listener className="org.apache.catalina.security.SecurityListener" />
  -->
  <!--APR library loader. Documentation at /docs/apr.html -->
  <!--
  <Listener className="org.apache.catalina.core.AprLifecycleListener" SSLEngine="on" />
  -->
  <!--Initialize Jasper prior to webapps are loaded. Documentation at /docs/jasper-howto.html -->
  <Listener className="org.apache.catalina.core.JasperListener" />
  <!-- Prevent memory leaks due to use of particular java/javax APIs-->
  <Listener className="org.apache.catalina.core.JreMemoryLeakPreventionListener" />
  <Listener className="org.apache.catalina.mbeans.GlobalResourcesLifecycleListener" />
  <Listener className="org.apache.catalina.core.ThreadLocalLeakPreventionListener" />

  <!-- Global JNDI resources
       Documentation at /docs/jndi-resources-howto.html
  -->
  <GlobalNamingResources>
    <!-- Editable user database that can also be used by
         UserDatabaseRealm to authenticate users
    -->
    <Resource name="UserDatabase" auth="Container"
              type="org.apache.catalina.UserDatabase"
              description="User database that can be updated and saved"
              factory="org.apache.catalina.users.MemoryUserDatabaseFactory"
              pathname="conf/tomcat-users.xml" />
  </GlobalNamingResources>

  <!-- A "Service" is a collection of one or more "Connectors" that share
       a single "Container" Note:  A "Service" is not itself a "Container",
       so you may not define subcomponents such as "Valves" at this level.
       Documentation at /docs/config/service.html
   -->
  <Service name="Catalina">

    <!--The connectors can use a shared executor, you can define one or more named thread pools-->
    <!--
    <Executor name="tomcatThreadPool" namePrefix="catalina-exec-"
        maxThreads="150" minSpareThreads="4"/>
    -->


    <!-- A "Connector" represents an endpoint by which requests are received
         and responses are returned. Documentation at :
         Java HTTP Connector: /docs/config/http.html (blocking & non-blocking)
         Java AJP  Connector: /docs/config/ajp.html
         APR (HTTP/AJP) Connector: /docs/apr.html
         Define a non-SSL HTTP/1.1 Connector on port 8080
    -->
    <Connector port="8080" protocol="HTTP/1.1"
               connectionTimeout="20000"
               URIEncoding="UTF-8"
               redirectPort="8443" />
    <!-- A "Connector" using the shared thread pool-->
    <!--
    <Connector executor="tomcatThreadPool"
               port="8080" protocol="HTTP/1.1"
               connectionTimeout="20000"
               redirectPort="8443" />
    -->
    <!-- Define a SSL HTTP/1.1 Connector on port 8443
         This connector uses the BIO implementation that requires the JSSE
         style configuration. When using the APR/native implementation, the
         OpenSSL style configuration is required as described in the APR/native
         documentation -->
    <!--
    <Connector port="8443" protocol="org.apache.coyote.http11.Http11Protocol"
               maxThreads="150" SSLEnabled="true" scheme="https" secure="true"
               clientAuth="false" sslProtocol="TLS" />
    -->

    <!-- Define an AJP 1.3 Connector on port 8009 -->
    <Connector port="8009" protocol="AJP/1.3" />


    <!-- An Engine represents the entry point (within Catalina) that processes
         every request.  The Engine implementation for Tomcat stand alone
         analyzes the HTTP headers included with the request, and passes them
         on to the appropriate Host (virtual host).
         Documentation at /docs/config/engine.html -->

    <!-- You should set jvmRoute to support load-balancing via AJP ie :
    <Engine name="Catalina" defaultHost="localhost" jvmRoute="jvm1">
    -->
    <Engine name="Catalina" defaultHost="localhost">

      <!--For clustering, please take a look at documentation at:
          /docs/cluster-howto.html  (simple how to)
          /docs/config/cluster.html (reference documentation) -->
      <!--
      <Cluster className="org.apache.catalina.ha.tcp.SimpleTcpCluster"/>
      -->

      <!-- Use the LockOutRealm to prevent attempts to guess user passwords
           via a brute-force attack -->
      <Realm className="org.apache.catalina.realm.LockOutRealm">
        <!-- This Realm uses the UserDatabase configured in the global JNDI
             resources under the key "UserDatabase".  Any edits
             that are performed against this UserDatabase are immediately
             available for use by the Realm.  -->
        <Realm className="org.apache.catalina.realm.UserDatabaseRealm"
               resourceName="UserDatabase"/>
      </Realm>

      <Host name="localhost"  appBase="webapps"
            unpackWARs="true" autoDeploy="true">

        <!-- SingleSignOn valve, share authentication between web applications
             Documentation at: /docs/config/valve.html -->
        <!--
        <Valve className="org.apache.catalina.authenticator.SingleSignOn" />
        -->

        <!-- Access log processes all example.
             Documentation at: /docs/config/valve.html
             Note: The pattern used is equivalent to using pattern="common" -->
        <Valve className="org.apache.catalina.valves.AccessLogValve" directory="logs"
               prefix="localhost_access_log." suffix=".txt"
               pattern="%h %l %u %t &quot;%r&quot; %s %b" />

      </Host>
    </Engine>
  </Service>
</Server>
  • If someone else is using port 80 you are out of luck – Ian Turton Jan 13 '17 at 16:39
  • @iant The thing is that the target server seems to run apache and GeoSever both on 80 and it seems to be OK. If possible, this seems to be an easier solution for me than the current OSGeo configuration. – tinlyx Jan 13 '17 at 17:32
  • 1
    Then someone is proxying – Ian Turton Jan 13 '17 at 17:33
  • @iant Any pointers on where the proxy settings might be? It seems that the server does not have mod_jk or a2enmod. The tomcat config is attached in the question. Is it somewhere in /etc/apach2? Both systems are Lubuntu 16.04 – tinlyx Jan 13 '17 at 17:40
3

GeoServer is a servlet and always runs inside a servlet container (e.g. tomcat, jetty, JBoss etc). So your question is "how do I change the port of the container that GeoServer is using?" which is what the question you point to is answering.

On the OSGeoLive VM there are two tomcat containers running one on port 8080 and the other (with GeoServer) on 8082. Apache httpd is running on port 80 to server static web pages and cgi based programs like MapServer.

To access GeoServer through port 80 the usual procedure is to use mod_jk to forward requests to machine:80/geoserver to localhost:8080/geoserver. This process is off topic here but widely covered elsewhere.

  • Thanks for your answer. Is there a way to avoid proxy and forwarding? I have a target server that I need to match which did not seem to have involved mod_jk. Please see my update. – tinlyx Jan 13 '17 at 16:28
1

This is what worked for me on OSGeo Live after some trials.

  1. OSGeoLive is running GeoServer on jetty. Hence the different port number 8082 than the tomcat port 8080.

  2. Given the packages already in OSGeo Live, I only needed to set up a proxy (as pointed out by @iant) by editing one of the apache2 configuration files, e.g. /etc/apache2/sites-enabled/000-default.conf and adding the following just before </VirtualHost> (and then restart apache2):

    ProxyRequests Off
    <Proxy /geoserver>
       Order deny,allow
       Allow from all
    </Proxy>
    ProxyPass /geoserver http://localhost:8082/geoserver
    ProxyPreserveHost On
    
  • Proxy * is a bit extreme. Why not just proxy /geoserver – nmtoken Jan 14 '17 at 11:48
  • @nmtoken Thanks. I've updated the answer as suggested. – tinlyx Jan 14 '17 at 20:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.