Recently converted to QGIS 2.18.2 from Mapinfo under Windows10. The Expression Builder in all the menus I've tried fails to display a popup window of values under the 'fields and values' selection when I click or right click on a selected field within the Expression builder window. Doesn't work for either 'top 10 unique values' or 'All unique values'.

However, if I right click a layer in the layers panel and choose 'filter' I can get pick lists for each field. I've uninstalled QGIS, removed all the plugins, re-installed, still no joy.

I figure I'm missing something simple, but have worked through lots of tutorials. Am I missing something obvious?

  • 2
    Thanks Guestagain, solved my problem. I thought it would be a simple thing. Was using small windows on my laptop, not big enough to stretch the dialog windows. Wouldn't have thought to drag to the left, either. And thank you Steven, that wasn't my problem this time, but i will remember to check my filter settings.
    – user89695
    Commented Jan 16, 2017 at 1:14

2 Answers 2


Perhaps there is a simple solution to your problem the same as a tip that helped me in the past:

  1. Open up one of the expression builder dialogs that you are having trouble with.
  2. Perhaps all you can see now is a blank panel to type your expression on the left, a search bar and the expression list panel?
  3. If this is the case, then the problem could simply be that the values panel is hidden.
  4. Hover your mouse over the farthest right line/panel border shown in the image below.
  5. Hopefully this allows your mouse to click-hold-drag to expand/resize the hidden "values" panel (dragging left) to display it as in the second image below?
  6. NB: expanding this panel only seems possible if the entire expression builder dialog is large enough to host/display the new panel. So if it doesn't seem to be working expand the entire dialog first. You have to drag a few inches to the left before it becomes visible.
  7. If so, you should be able to right-hand click or use the new buttons in the values panel to display the layer's field values.

Hope this helps if it was the issue.

enter image description here

enter image description here

[using QGIS 2.18.2 on win7 for this potential solution]


Normally, manually clicking on All unique button should work.

This can happen if you have a filter applied to your layer. You mention using filters, so it might be worth checking.

I set up a filter with the expression


on one of my fields.

That will never be true, so all features are filtered out. Now, if I try to list all values or top 10 values, nothing.

To clear the filter, Right-click the layer, choose Filters and click on Clear

Thank you for pointing out the right-click shortcut on the fields list, I hadn't seen that before!

enter image description here

If this still doesn't work with filters removed, it may be a bug. I'm on QGIS 2.18.1 and couldn't see this happening unless I applied a filter.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.