2

I've been usign QGIS Server 2.12 and QGIS Desktop 2.12 for several months without problems.

Now I installed QGIS 2.18.3 to use some new features I consider them interesting but when I open my QGIS project the WFS layers (served by QGIS server 2.12) fail to load.

Is there any WFS-T protocol update in >2.12 versions?

Is it because my WFS urls have the VERSION=1.0.0 parameter and maybe QGIS Desktop 2.18 does not handle 1.0.0 requests?

enter image description here

EDIT 18.01.2017:

If I add the WFS layer in QGIS 2.18 it adds ok. The problem comes when trying to open a QGIS project saved in 2.12 with QGIS 2.18.

I added a layer to canvas and saved the project in QGIS 2.12, the layers' datasource is as follows:

<datasource>http://eudala2.getxo.eus/qgis/qgis_mapserv.fcgi.exe?map=D:\OSGeo4W\apps\qgis\bin\test\vialidad_borrar.qgs&amp;SERVICE=WFS&amp;VERSION=1.0.0&amp;REQUEST=GetFeature&amp;TYPENAME=getxo_turismo_pois_old_borrar&amp;SRSNAME=EPSG:4230</datasource>

If I do that in QGIS 2.18 with the exact same WFS layer I can see that the data in datasource is splitted into different params:

<datasource> restrictToRequestBBOX='1' srsname='EPSG:4230' typename='getxo_turismo_pois_old_borrar' url='http://eudala2.getxo.eus/qgis/qgis_mapserv.fcgi.exe?map=D:\\OSGeo4W\\apps\\qgis\\bin\\test\\vialidad_borrar.qgs' table="" sql=</datasource>

What could I do to open my QGIS 2.12 projects with hundreds of layers (without having to create the projects in QGIS 2.18 again) ?

  • do you get an error message? – Ian Turton Jan 17 '17 at 16:11
  • @iant Yes, those layers are not loaded, and when I click on Apply button all the rows in that list turn red and won't load. I tried changing VERSION parameter to 1.1.0 and to 2.0.0 without success... – Egidi Jan 18 '17 at 9:15
  • is there anything in the log file to explain what went wrong? - also can you paste one of the links in to the question it they are publicly available – Ian Turton Jan 18 '17 at 9:17
  • @iant I edited the OP and added a url and extra info – Egidi Jan 18 '17 at 11:26
1

I made a quick node.js script that asks for a QGIS project path and creates a new .qgs with the correct WFS/WMS layers' datasource string. I know it's not the most elegant code but it worked for me. You can get it from here:

https://github.com/jaitor1/upgradetoqgis218

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.