5

I've been searching for a solution to this, but cannot seem to find an answer. I have a map where some stacked markers have been offset to be visible on the map. This makes their symbol offset in the layers panel, and subsequently in composer legends. I've played with spacing and other settings, but cannot get them to line up without removing the offset.

Is it possible to prevent symbols that have an offset applied in the map from having that offset displayed in the legend?

Offset symbols

  • 1
    Same here. It's really annoying. Legends look pretty ugly because of this. – Dolf Andringa Jan 27 '18 at 3:51
  • Above solution works for the Layers panel as well as the "Legend panel" in print composer. But sorry to say: I realized that is has no effect on the legend in the print composer canvas and final printed map :-( (at least not in QGIS 3) – Morten Dec 17 '18 at 18:25
  • This does not provide an answer to the question. Once you have sufficient reputation you will be able to comment on any post; instead, provide answers that don't require clarification from the asker. - From Review – Vince Dec 17 '18 at 18:56
  • No I do not solve the problem - I wish I could as I have the same problem myself! But I point out, that the previous suggestion is not a solution, so I find my comment very relevant! – Morten Dec 17 '18 at 19:05
2

If you use datadefined overrides for the "Anchor point", and all features are not anchored the same, this will (hopefully) leave the symbol in the center in your legend. This is not a solution, only a work around. For now. enter image description here

0

I found a simple work around which involves printing the composer into a pdf and then editing the pdf (edit text and images). Align your symbols and then export the file as a JPG (or not if you prefer pdf).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.