0

So I have a shapefile which is divided into 7 habitat categories, with 1845 polygons, and I am trying to dissolve it so I only have 1 line showing each habitat with the total area.

After dissolving, I can see 1804 entries in the attribute table, so it's obviously doing something, but it hasn't dissolved to only one of each habitat.

  • I think dissolving tool dissolves adjacent and overlapping polygon (AND optionally) with same attributes – chenghopan Jan 17 '17 at 22:44
  • 1
    Please edit the question to specify the parameters used (they can be found in the geoprocessing Results log). Of specific importance: What value was in the MULTI_PART / SINGLE_PART flag? – Vince Jan 17 '17 at 22:47
  • Please post a screenshot of the parameters and results of the Dissolve Tool. – dpw4050 Jan 17 '17 at 22:59
  • 1
    check you don't have a selection when your running the tool – Mike Jan 18 '17 at 0:04
1

enter image description here

  • In the Dissolve tool: make sure you have ticked the habitat field for the dissolve field
  • In the Dissolve tool: make sure you tick or untick 'Create Multipart features' depending on the result you want. It sounds like you should try Multipart first.
  • In ArcMap: make sure you do not have any features selected

More info on the Dissolve tool: http://desktop.arcgis.com/en/arcmap/10.3/tools/data-management-toolbox/dissolve.htm

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.