0

I'm trying to view some Environment Agency (EA) WFS data in ArcMap 10.2.2. I've installed the Data Interoperability extension and enabled it. I've added a new connection with the url below. It should contain the EA's main river dataset. When I load the WFS, the layer appears in the table of contents, but contains no features.

EA Main River WFS URL: http://environment.data.gov.uk/ds/wfs?SERVICE=WFS&INTERFACE=ENVIRONMENTWFS--25dde009-ba7d-40de-8380-c5c3bb32ccdc&VERSION=1.0.0

(WFS available from http://environment.data.gov.uk/ds/catalogue/#/catalogue)

  • I should add, I'm able to view the WFS correctly in QGIS 2.18, but my colleagues require this to be viewable in ArcMap. – davehughes87 Jan 19 '17 at 10:09
  • the GetCapabiliites response shows a different location for the actual service. Perhaps ArcMap can't handle the redirect. What if you use the actual service URL advertised? – nmtoken Jan 19 '17 at 10:27
  • Are you using the GML Simple Features profile? gis.stackexchange.com/questions/31766/… – PolyGeo Jan 19 '17 at 10:27
  • Hi nmtoken and Polygeo. Thanks for the responses - I'm not entirely sure what you both mean. What I do know is I've used this method - resources.arcgis.com/en/help/main/10.1/index.html#/… with the URL above. What is the service URL? And I doubt I'm using the GML Simple Features profile. – davehughes87 Jan 19 '17 at 10:44
  • if you follow the link I give in my comment (which is your original URL with parameters to do a GetCapabilities request) you can see that the listed GET URL for the service is actually <Get onlineResource="http://www.geostore.com/OGC/OGCInterface;jsessionid=wZlXLOq+AimpsFhn4WQsUXjV?SESSIONID=1326425477&INTERFACE=ENVIRONMENTWFS&"/> So what if you use that URL as your service endpoint. – nmtoken Jan 19 '17 at 11:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.