I'm trying to install GDAL on a Mac so I can use ogr2ogr against an Oracle database. This was as easy as:

brew install gdal

However, it seems the Homebrew edition of GDAL doesn't ship with Oracle support. When I list install options with brew options gdal, I see flags for thigns like MySQL and Postgres but nothing for Oracle. Does anyone know how to build GDAL using Homebrew but include Oracle/OCI support?

  • Have you tried the method in my answer? I rarely use Macs so some feedback would be useful
    – user2856
    Commented Jan 25, 2017 at 22:30
  • Yes, thanks for sharing that. That seemed to be the right package but because of the nature of Oracle it requires you to place a zip file of the Instant Client in the Homebrew cache. I already had the IC installed and didn't want to muck with it, so I opted not to use this. But it may be helpful for others, so I'll mark it as solved. Thanks!
    – bertday
    Commented Jan 26, 2017 at 0:52

1 Answer 1


Have you tried osgeo4mac?

brew tap osgeo/osgeo4mac 
brew install osgeo/osgeo4mac/gdal1-oracle
#or for GDAL 2x
brew install osgeo/osgeo4mac/gdal2-oracle

More info on taps is available in the homebrew documentation.


osgeo4mac is broken on Big Sur - #1410.

  • As of 2021-09-19 this no longer works. Or at least for Big Sur 11.5.2. Tapping osgeo causes a lot of errors and packages do not install.
    – jebyrnes
    Commented Sep 20, 2021 at 3:58
  • @jebyrnes thanks, have added a link to the relevant issue
    – user2856
    Commented Sep 20, 2021 at 6:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.