1

I recently installed QGIS 2.18.3. I loaded some WFS layers (1.1.0) I have previously loaded using 2.14.9 and noticed the record count had doubled (and one time they trippled but I can't replicate that). The duplication was consitent with a few layers I checked from the same URL.

I tried the same WFS URL using 2.18.0. I have one layer with just one point feature and 2.18.0 returns only one feature however, in other layers 2.18.0 seems to randomly duplicate features and drops other features. For example, 2.18.0 returns 1217 features in a layer with 1220 features - some missing and some duplicated.

I tried a 'select distinct * from table' query using 2.18.3 and get 1186 features returned (2372 without distinct). I can't see any duplicate values but there are obviously some missing.

Are there issues with WFS in 2.18.3?

Further information: I have confirmed that the WFS is being served with Geoserver 2.7.0. I have one layer that has an ID (it is not titled FID) that is unique. The IDs range from 1 to 48 (I'm assuming this meets the requirement of a WFS FID??). If I use ArcGIS 10.4 Interoperability extension, QGIS 2.6.0 or QGIS 2.18.0 then I get the correct number of features. If I use 2.18.3 then I get exactly twice the number of records. It seems the request is made twice and I get one record set appended to another.

  • Features which come from WFS should have unique and persistent FIDs and by those QGIS should know to filter out the duplicates if it receives such with subsequent requests to the WFS service. Fids are hidden from the user so debugging is not very simple. It may be also that WFS server is misconfigured and fids are not persistent. – user30184 Jan 24 '17 at 5:41
  • Is there any advice about how I can determine if they are persistent or ensuring at the Geoserver 2.7.0 end that they are persistent? – Colin Jan 24 '17 at 23:02
  • I have at least one layer with an ID column. I asked another person to check the WFS using an earlier version of QGIS 92.6.0) and this version also return 48 records. I used 2.18.0 and it also returns 48 records. Version 2.18.3 returns 96 records. – Colin Jan 25 '17 at 0:14
  • For checking the fids you should study the GML data that comes from the server. Make identical WFS GefFeature requests and check if fids remain the same. – user30184 Jan 25 '17 at 5:30
  • I checked the FIDs and they are not persistent. Probably not the question for here but is it a later version of Geoserver that has persistent FIDs? – Colin Jan 31 '17 at 1:03
1

I posted a question here: Persistent FID in Geoserver WFS asking about persistent FIDs as per the above. The answer referred me to the geoserver documentation. I had the geoserver owner change the setting as per the documentation and now I get persistent FIDs and I do not get duplicated records.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.