3

Im running a query with ST_SubDivide() and receiving the error bellow.

ERROR:  The GEOS version this PostGIS binary was compiled against (34) doesn't support 'ST_Subdivide' function (3.5.0+ required)

Im on centOS7 with:

$ rpm -qa postg*
postgresql95-9.5.4-2PGDG.rhel7.x86_64
postgis2_95-client-2.2.2-3.rhel7.x86_64
postgresql-libs-9.2.15-1.el7_2.x86_64
postgresql95-libs-9.5.4-2PGDG.rhel7.x86_64
postgis2_95-2.2.2-3.rhel7.x86_64


$ rpm -qa geo*
geos-3.5.0-1.rhel7.x86_64
geos-devel-3.5.0-1.rhel7.x86_64

Question : How should i interpret this error of 'The GEOS version this PostGIS binary was compiled against (34)' when on my view i have GEOS 3.5.0 installed , what are my options ?

  • compile postgis2 from source, using the desired version. or find a pre-compiled version that was compiled with the said version. if you need help on how to compile postgis2 in your system please refer at: postgis.net/docs/manual-2.2/postgis_installation.html#PGInstall – nickves Jan 24 '17 at 13:54
  • 1
    Can you run the query: select postgis_full_version(); and paste the results here? – jgrocha Jan 25 '17 at 11:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.