2

I have a large database in Filemaker. To get this joined with a feature class in ArcGIS I have to make an ODBC connection. I do this in the 32-bit ODBC in windows because ArcGIS is 32-bit. In Arccatalog I then have to make an Oledb connection to the ODBC to get the table translated in ArcGIS.

This seems to work up until the point I want to add symbology based on the joined table. The text fields can't be used to add symbols. The number fields do work and the table does show the values correctly.

some thoughts:

  • the text fields sometimes contain 1000000 characters
  • could there be an office involvement?

What could be going wrong?

ArcGIS 10.3.1 Filemaker 14 Windows 7 (64-bit)

  • 1m characters is a CLOB field. Symbolization on CLOBs is not likely to ever be permitted. You need to create a new column with a reasonable number of distinct values in a character field (width < 32k, preferably <256) or integer field for symbolization. – Vince Jan 25 '17 at 11:53
  • 1
    The above should be an answer, not a comment. I'm pretty sure it is right. – HeyOverThere Jan 25 '17 at 15:43
1

You can limit the "Maximum number of characters" in the Field-Options-Dialogue (Validation) in Filemaker. Limit the number to your needs.

0

As commented by @Vince:

1m characters is a CLOB field. Symbolization on CLOBs is not likely to ever be permitted. You need to create a new column with a reasonable number of distinct values in a character field (width < 32k, preferably <256) or integer field for symbolization.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.