3

I am trying to clip the required portion of raster using polygon as a mask layer. The raster image is in .bil format. While loading the raster, I chose CRS as WGS84. Then I added the vector layer for which clipping was to be done. Using "Clipper" I tried to create clip layer. But it showed certain error as "Warning : the input vector layer has a SRS, but the source raster dataset does not. Cutline results may be incorrect." Both raster and mask layer have same CRS WGS84

  • A question about your vector layer, used as the cutline (to mask). Does it contain only one polygon, or several polygons? – Kazuhito Jan 25 '17 at 17:46
  • Only one polygon, sir – Kaustubh Sunil Bhave Jan 25 '17 at 18:11
  • 1
    Thank you. Then (1) can you see if your project CRS is set to On-The-Fly? (2) if OTF is on, can you toggle off OTF, then reload both your raster image and the polygon? ... This is just to double-check to see if these layer are aligned OK under the same CRS without a help by OTF. – Kazuhito Jan 25 '17 at 18:27
1

As the warning states there seems to be a problem with the raster SRS...Maybe you try to assign one by using "Assign projection" tool (Raster -> Projections -> Assign Projection). Make sure you have the same EPSG-CRS for your raster and vector layer (sorry wanted make a comment, but my reputation seems to be too low as I just spend some on a bounty...)

0

If you have to choose the CRS of the raster file, QGIS was not able to autodetect it. The clipper function is an external command (though called from the QGIS GUI), so it does not know the CRS setting you made.

To do it correctly, you have to save the raster file to another format that includes CRS information, like Geotiff does. Then load the vector data, turn On-the-fly-reprojection off, and see if both files align. If so, the clipping will work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.