5

I run r.reclass from QGIS process toolbox (ie it works fine if i run from GRASS) and get this error :

2017-01-26T12:25:14 2   Uncaught error while executing algorithm
            Traceback (most recent call last):
              File "C:/PROGRA~1/QGIS2~1.18/apps/qgis/./python/plugins\processing\core\GeoAlgorithm.py", line 203, in execute
                self.processAlgorithm(progress)
              File "C:/PROGRA~1/QGIS2~1.18/apps/qgis/./python/plugins\processing\algs\grass7\Grass7Algorithm.py", line 274, in processAlgorithm
                func(self)
              File "C:/PROGRA~1/QGIS2~1.18/apps/qgis/./python/plugins\processing\algs\grass7\ext\r_reclass.py", line 45, in processCommand
                with open(tempRulesName, "w") as tempRules:
            IOError: [Errno 13] Permission denied: u'tmp1485429914724

The same process works fine in GRASS.

I have no admin issue / access in windows and my user is administrator

  • Make sure the raster name is less than 13 characters or try saving it on a different directory. – charlotte Nov 27 '17 at 23:34
3

This appears to be a bug in "Processing", in the file r_reclass.py. The path to the rules file must be missing, hence it is not found and fails.

I have created a bug report at http://hub.qgis.org/issues/16128

  • Have exactly same issue on mac. Is it possible to fix it with the new file r_reclass.py ? where i have to put it ? – Tim C. Oct 2 '17 at 14:26
  • I think that QGIS 2.18.3 or newer will contain the fix. – markusN Nov 30 '17 at 16:51
  • Running into the exact same error with QGIS.2.18.15, is there any possible fix? – 15Step Jun 7 '18 at 13:03
0

Hi I had this problem with the mosaic module from SAGA. I tried it with QGIS 2.14 and 2.18 fresh installation on windows 7. First I couldn't even locate the mentioned .bat files myself, so I figured it might have something to do with user profiles. Running the program as administrator didn't work. I realised the files might be hidden and that could be the reason. I un-hid the folder name c:\user\myname\ and all folders and files in the user\myname.qgis2 folder (including sub levels), and.... (to my surprise)... it worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.