1

I have geographic data for the road network.

I changed my data from a geographic coordinate system (blue line) to a projected coordinate system (red line), it worked perfectly for all of my data, except for one year.

As you can see from the second image, a horizontal red line (road) appears from the centre south of the island and stretches off the land.

To try and identify the road, I used the select features tool. It only identified the red line on the land, when I select it off the land, nothing appears (like the red line is not there at all)

Do you know why this would happen? Or, how I can fix it? If I remove the red line, then I will be removing part of my data.

I would treat it as measurement error, but the first map appears does not have this error.

enter image description here

enter image description here

  • What are the source and target system? And could you share the part of data that causes the red line to appear? – Elektordi Jan 26 '17 at 19:52
1

Okay, my comment got too long. Some things to try. What you have is a 'zinger.'

Try running the check geometry tool on the bad data. If it finds anything, try the repair geometry tool.

I've seen zero-length arcs/curves do this.

You also might try copying the data, and then start editing out the good features. Once you've identified the bad feature, try editing it to see if you can find anything odd about it.

You might also try copying the dataset to a new one, new feature class or shapefile. That can sometimes fix problems in the geometries or the file.

  • Thank you for your help. I tried everything that you said here, but nothing worked. I ended up getting the file remade instead, and the error no longer appears thankfully. – Kelly Feb 17 '17 at 10:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.