3

I'm trying to place labels in the form of a callout box at the end of a line using the Maplex label engine (otherwise I was not able to keep the label horizontal but still at the end of the line). I need it to be EXACTLY 2 lines, and the text is hardly changing at all for the different features. What I need:

Project Start Location
Milepost 263

enter image description here

What I'm getting:

Project Start
Location
Milepost 262

enter image description here

or everything on a single line.

The only thing changing is the number at the end. However, the label engine isn't respecting any of the settings I have tried, so I need a workaround. It always makes the label either 3 lines or 1.

What I've tried:

  • Setting maximum number of lines to 2. This makes the label take up a single line. It doesn't seem to matter what I change for the minimum and maximum number of characters per line (right now it's set to max 30).

  • Using "VBNEWLINE" in the label expression, and setting max lines to either 2 or 3. It just ignores it, and either goes to 1 line or 3.

  • Putting a comma in the expression, unchecking "visible" and checking "forced split" and "split after" for commas. When I set max lines to 2, it put everything on a single line and showed the comma. When I set it to 3, it hid the comma but broke the lines as before.

  • Using VBNEWLINE or "Project Start Location" & chr(13)+chr(10) & "Milepost " &[BMP] and turning off label stacking. This put everything on a single line.

  • The Maplex tab setting "remove extra line breaks from label" in the label expression settings is unchecked.

  • Removing surrounding labels in the map by deleting annotations and turning off layers.

I'm out of ideas.

  • Can you include pictures of what you are trying to achieve, and also of the closest that you have been able to get to that so far, please? – PolyGeo Jan 26 '17 at 21:29
  • Try VBTAB gis.stackexchange.com/questions/177619/… – Mapperz Jan 26 '17 at 21:32
  • Try unchecking stack label in the label settings. I believe line breaks are still honored while blocking the automatic line breaks. – amasephy Jan 26 '17 at 22:49
1

Things were getting stranger and the label started getting "stuck" on a single line even when I used the changes that previously put it on one line.

I quit without saving my changes to the labels.

What worked was restarting ArcMap, then using

"Project Start Location" & VBNEWLINE & "Milepost " & [BMP]

in the expression and unchecking "stack labels." This really should have worked the first time, but ArcMap was getting weird. Should have tried restarting it first.

  • ETA: This solution does not seem to work for the labels at the edge of the map (in the lower right, specifically). Those still stack to 3 lines in situations where they don't show up at all unless "never remove (place overlapping)" conflict resolution is checked. – Ella Jan 27 '17 at 19:06
  • Do you have feature weights set for other layers in the conflict resolution tab? Also try labeling this feature on a map with only that feature and without a feature weight set to rule out that this is affecting it. – amasephy Jan 28 '17 at 0:04
0

I lucked in by setting a 15% hard constraint label buffer (Label Density tab) for a point featureclass. Stacking worked properly after that too. Restarting didn't make any difference for me. The issue was on the lowest right label where the label could only land on the masked area.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.