2

I am trying to create a vector grid (polygons) but the tool Vector>Research Tools>Vector grid lets QGIS crash all the time. I tried different grid extents (same as canvas, by another layer), resolutions, opened a blank project ... but it keeps on crashing.

I am using the newest QGIS 2.18.3

5

I'm using QGIS 2.18.3 and it works well for me.

You may try checking two things:

  1. Check if you are in a Projected Coordinate System;
  2. Take care of the units of measurement for spacing: the Vector grid tool uses 0.0001 by default for both X and Y spacing, so it may cause a crash of QGIS due to the huge number of features are being created.
3
  • 1
    For completeness, the default value makes sense for CRS using degrees, but not for those using meters or feet as units.
    – AndreJ
    Jan 31 '17 at 10:03
  • Thank you for the quick answers! The problem was the grids resolution/spacing. Although I already thought that the default spacing was to small, the highest spacing I tried out was 5m. Apparently, this was still to small considering the extent (3435259.5439,3439679.5439,5412210.3201,5420470.3201). Now with 20m it works. Jan 31 '17 at 11:06
  • I'm glad it worked for you!
    – mgri
    Jan 31 '17 at 11:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.