0

I'm new with using servers but I've been using ubuntu for more than a year now. I've tried to install Zoo-project by following the instructions on the website : http://zoo-project.org/docs/install/debian.html. At first I tought that it was easy but when I try to reach the testing page : http://127.0.0.1/cgi-bin/zoo_loader.cgi?ServiceProvider=&metapath=&Service=WPS&Request=GetCapabilities&Version=1.0.0 I've an error message saying :

" This site can’t be reached

127.0.0.1 refused to connect. Try: Checking the connection Checking the proxy and the firewall "

I have the feeling that there is something I'm doing wrong. I don't know what... I've never started an server.

When I'm doing HTML, I start a server with python2 -m SimpleHTTPServer 8000 and I can see it in the port 8000 of 127.0.0.1 but when I try to use ZOO-project the instructions doesn't telling me how to start the server.

Do I need to install an apache server on my computer ? What is the step that I'm missing here ?

I don't know if I'm clear enough... I'm a GIS french guy after all lol.

0

Indeed, you should have a HTTP Server and have defined the cgi-bin directory correctly for Apache (which is traditionally the case per default in most GNU/Linux distribution).

  • That was it. I've delete apache2 and his configuration and then reinstall it and I've run in the terminal code sudo a2enmod cgi sudo service apache2 restart code and now I can connect QGIS to my server. Thanks a lot ! Vous avez un vraiment beau projet ! – Miguel Sanchez Feb 2 '17 at 14:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.