3

I have been trying to install python gdal with OSGEO for some time now with no success. I have removed. I have tried with "Express and Advance" as suggested by OSGEO4W site.

The error is always "No module named 'osgeo' or gdal", the command line also does not recognise an internal program.

  • If it is in Windows try to run it in Osgeo shell rather than normal command prompt – S. Thiyaku Feb 3 '17 at 7:30
  • I have tried but still getting the same message – Asanda Feb 3 '17 at 8:26
  • Check whether the path is correct? echo %PATH% command list all paths in command prompt. Check python path also ? – S. Thiyaku Feb 3 '17 at 10:54
  • What python version do you have? – Dmitry Baryshnikov Feb 6 '17 at 7:34
  • The echo %PATH% also includes paths for previously installed python versions, I removed python 3.4 then installed 2.7 – Asanda Feb 6 '17 at 11:04
2

Summerizing the 4 steps from the answer of Khoa:

  • go to this site to download appropriate windows binaries (once you've clicked on the appropriate version of GDAL bianaries, select GDAL core to download the main fucntionnalities).

  • install GDAL with default (or not ?) settings

  • return to the page where you got GDAL core and download GDAL python bindings to work with your python version

  • install python bbindings

1

Follow the 4-step instruction on this site: https://sandbox.idre.ucla.edu/sandbox/tutorials/installing-gdal-for-windows

I found this site after hours of failing in installing osgeo.

Good luck.

  • 3
    Thanks for providing this answer. Can you summarize the 4 steps on your link. In case the link changes in the future, there is some record of what the user must to if they encounter the same issue. – Mattropolis Aug 18 '17 at 16:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.