Is it possible to set certain parameters of tools within set up models when opening a saved model (not edit, but double click and running)

I am talking about being able to set certain tool specific parameters such as distance in the "fixed distance buffer" tool as model parameters that then can be changed in the model window before running the model?

I treid to set up strings but the the tools withion the models don´t allow for triggering the string variables. So far only in- and output layers can be specified but not the input fields of desired tool-specific parameters

1 Answer 1


You need to set a number instead of a string. Double-click on the Number parameter and set your default distance (I called it "buffer distance" in the image below):

enter image description here

After you have done this, trigger it from the dialog of the tool:

enter image description here

Finally, save your model and you have done. You will able to directly set a different distance before running the model.

  • thanks a lot! You solved this problem for me. Do you know if it is also possible tto change the order of parameters in the model?
    – hilpers
    Commented Feb 4, 2017 at 17:39
  • I'm glad it worked for you! What do you mean with "changing the order of parameters"?
    – mgri
    Commented Feb 4, 2017 at 17:42
  • when opening the model (double click), the input field of the specified parameter is asked after the output location of the output. I would like to change the positions of these parameters
    – hilpers
    Commented Feb 4, 2017 at 17:46
  • Sincerely I don't know if it is possible. Thisis what I see when running my model and actually I'm curious to kwow why you see a different behavior...
    – mgri
    Commented Feb 4, 2017 at 17:53
  • maybe it has to do with the order I set the parameters when creating the model. The distance variable was the last one I specified. It´s not such a big deal. You helped me out. Thanks a lot again!
    – hilpers
    Commented Feb 4, 2017 at 17:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.