1

I am trying to install grass7 addons locally. I have downloaded them and am using the url=path version of the g.extension command line. I get an error as follows:

g.extension url=/home/user/source/grass7-addons/grass7/ -g
List of available extensions (modules):
Fetching list of extensions from GRASS-Addons SVN repository (be patient)...
WARNING: Flag 'g' ignored, addons metadata file not available

I previously downloaded a metadata file from somewhere other than the svn repository. I am trying to find it again (and I hope this question will make it easier to find in future).

Update: I examined g.extension source. In the absence of the metadata file, it won't read the available extensions and won't compile them. It was possible to compile extensions manually by setting the install directory for grass to world writeable, then compiling each extension manually:

grass72
sudo chmod -R a+w $GISBASE
cd /path/to/extension/source
make MODULE_TOPDIR=$GISBASE <extension_name>
0

The modules.xml file is located here: https://grass.osgeo.org/addons/grass7/modules.xml

For example metadata for d.explanation.plot

<task name="d.explanation.plot">
  <description>Draw a plot of multiple rasters to explain a raster operation for example a + b = c</description>
  <keywords>display,manual,raster</keywords>
  <binary>
    <file>scripts/d.explanation.plot</file>
    <file>docs/man/man1/man1/d.explanation.plot.1</file>
    <file>docs/html/d.explanation.plot.html</file>
    <file>docs/html/d_explanation_plot.png</file>
  </binary>
</task>

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.