2

ArcMap 10.3.1 is giving us an error of "Unable to save edits. FDO error: -2147154947". This is not contained in the ESRI list of FDO errors: http://resources.esri.com/help/9.3/ArcGISEngine/ArcObjects/esriGeoDatabase/fdoError.htm

Here is some more information about our environment and under what circumstances the error occurs:

Once a user receives this error, they will continue to receive this error on every subsequent attempt to Save Edits. The only way we know to fix the problem is to restart ArcMap and lose all edits since the last save. The database we are using is an ArcGIS 10.3.1 enterprise multi-user geodatabase hosted on MS SQL Server 2012. The client software we are using to access the database is ArcMap 10.3.1. There are multiple versions in the database, and each version is being edited by a single user. We can have as many 16 users editing different versions simultaneously. Users will typically save edits every 15-20 minutes, and then reconcile and post their edits a couple times a day. Archiving is enabled on the GDB feature classes, as well as editor tracking. We have determined that this error number is probably an HRESULT, but we are unable to find any documentation from Esri or Microsoft for this particular error.

What is the specific meaning of this error code and message. In other words, what specifically is preventing ArcMap from saving the edits?

Edit:
The error happened again and this time we were able to retrieve the SDE log file from the client machine. I have substituted "client_machine_name", "database_name" and "feature_class_name" for the actual values for clarity.

[Fri Feb 24 13:57:07 2017] [619] [client_machine_name] DB_registered_table_trim_state (database_name.DBO.feature_class_name,38063) Execute Immediate error (-1021).
[Fri Feb 24 13:57:07 2017] [619] [client_machine_name] Error when updating kept rows in geometry table.
[Fri Feb 24 13:57:07 2017] [619] [client_machine_name] Warning: Unable to trim state 38056->38063 for table database_name.DBO.feature_class_name, error = -1021

closed as off-topic by PolyGeo Jun 23 '17 at 22:40

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This problem cannot or can no longer be reproduced. Changes to the system or to the asker's circumstances may have rendered the question obsolete, or the question does not include a procedure to enable potential answerers to reproduce the same symptoms. Such questions are off-topic as they are unlikely to help future readers, but editing them to include more details can lead to re-opening." – PolyGeo
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    Have a look at geonet.esri.com/thread/113423 – Midavalo Feb 7 '17 at 23:28
  • I would suggest that it's an extended geodatabase (SDE) error disguised as an Esri error... It looks like it's time to contact Esri support. Have a look at your remote database log files first though, all the info I can find is as a lack of space to save error - but it could just as easily be table locked for some reason. Can you explain a bit more about how you're connecting and editing... directly using a version or checkout; is everyone using the same credentials or do they have their own? – Michael Stimson Feb 8 '17 at 0:46
  • There is space to save on the server. We are not using checkout replicas; we are using a direct connection to the SDE database, with each user creating and editing their own version. Users connect with their own credentials (OS authentication), but they are part of a Windows Active Directory group that is mapped to a SQL Server login, and that role is granted Select/Insert/Update/Delete privileges in Arc. – tekim Feb 8 '17 at 21:11
  • 1
    It sounds like you've setup SDE correctly with respect to the usual pitfalls.. how is your network? Are you accessing via intranet (wired or wireless) or a thinner connection (WAN)? Intermittent problems can be caused by network issues or (rarely) virus checking, defragmenting or other utility software locking files - but this would be a very rare case. I say it's time to contact Esri support as they have access to resources that are not publicly available. – Michael Stimson Feb 9 '17 at 4:55
  • 1
    @tekim The steps are in the link I posted. You'll see it's a clunky process but it might get you close. resources.esri.com/help/9.3/arcgisengine/dotnet/… – Ken Feb 24 '17 at 3:40
0

The steps are in the link I posted. You'll see it's a clunky process but it might get you close.

http://resources.esri.com/help/9.3/arcgisengine/dotnet/a3bd05c8-64a6-4dd4-acb3-0d10b021f2f8.htm

0

I think this is one where you may need to ask your Esri support via a Maintenance contract.

The same error appears in a GeoNet thread but the Esri response on that informal channel was:

Have you run into problems with SQLite databases? If, so can you describe them?

  • ESRI tech supports said it was "probably" due to a network issue. Difficult to believe that there was a network issue on a LAN when all of the components are within a few feet of each other and there was no other sign of such a problem, and that SDE is so fragile as to cause the loss of edits for what could only have been a extremely brief (microseconds) network issue, if there was a network issue at all. – tekim Jun 23 '17 at 18:14

Not the answer you're looking for? Browse other questions tagged or ask your own question.