0

I am working with ArcGIS 10.3.1.4959 (License type: Advanced), and am trying to merge 3 point shapefiles together using the Data Management Tools -> General -> Merge functionality from ArcToolbox.

Between the shapefiles the fields do not match. But what's important is that they share the same coordinate system and geometry, being all points.

When I apply the Merge tool, the final result is never consistent: sometimes it includes the last element of the 1st shapefile, and sometimes the 1st shapefile is not at all present. I always get all the elements in the last two shapefiles, however. All three shapefiles are within the same Geodatabase.

I have tried to use Data Management Tools -> General -> Append but I am forced to use the NO_TEST schema type, losing useful information.

Why does this happen, and what can I do to walk around this obstacle?

1
  • Please edit the question to specify the license level of Desktop.
    – Vince
    Feb 8 '17 at 12:22
0

This does not clarify the reason why this problem occurred, but to advise on a workaround that seemed to do the trick.

It consisted of:

  1. Using Data Management Tools -> General -> Merge to merge together the 1st with the 2nd shapefile, so to create a "byproduct" shapefile;
  2. Using Data Management Tools -> General -> Merge to merge the "byproduct" to the 3rd shapefile, so to obtain the intended outcome.

By simply counting the total number of points in the outcome, this seems to have worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.