3

I have just done a fresh install of ArcGIS Desktop 10.4.1 on my PC (new PC, never had ArcGIS on it before). I tried to run the Union tool and it gave me an error

ERROR 001143: Background server threw an exception.
ERROR 001143: Background server threw an exception.

(yes it said it twice)

Re-running the tool gave the same error (several attempts).

The help doesn't really give much info as to what may have caused it.

enter image description here

Running with background geoprocessing disabled as suggested in the help is successful, but when enabled again it fails.

enter image description here

I hadn't yet installed the 64bit Background Geoprocessing, so I've installed that and now the tool works fine without error.

What are the requirements to run Background Geoprocessing in ArcMap? Does Background Geoprocessing in ArcGIS require the 64bit Geoprocessing to be installed to run from within ArcMap, or is this just coincidence that it now runs (perhaps due to the restart of ArcMap?

  • 2
    I loathe background geoprocessing, since I usually need to wait around until it's finished anyway, but I usually need to disable it, even before 64-bit BGDT is installed, so no, 64-bit is not required. There may be an environment complication not addressed by your question. – Vince Feb 11 '17 at 0:11
1

Like @Vince, in ArcGIS Desktop, I very rarely run Background Geoprocessing and I never install 64bit Background Geoprocessing so whenever I do run it I am running 32bit Background Geoprocessing successfully.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.